我是靠谱客的博主 心灵美蜜蜂,最近开发中收集的这篇文章主要介绍2016CCPC东北地区大学生程序设计竞赛-Mr. Frog’s Game Mr. Frog’s Game,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Mr. Frog’s Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
One day, Mr. Frog is playing Link Game (Lian Lian Kan in Chinese).



In this game, if you can draw at most three horizontal or vertical head-and-tail-connected lines over the empty grids(the lines can be out of the whole board) to connect two non-empty grids with the same symbol or the two non-empty grids with the same symbol are adjacent, then you can change these two grids into empty and get several more seconds to continue the game.

Now, Mr. Frog starts a new game (that means there is no empty grid in the board). If there are no pair of grids that can be removed together,Mr. Frog will say ”I’m angry” and criticize you.

Mr. Frog is battle-scarred and has seen many things, so he can check the board in a very short time, maybe one second. As a Hong Kong Journalist, what you should do is to check the board more quickly than him, and then you can get out of the room before Mr. Frog being angry.
 

Input
The first line contains only one integer T ( T500 ), which indicates the number of test cases.

For each test case, the first line contains two integers n and m ( 1n,m30 ).

In the next n lines, each line contains m integers,  j-th number in the i-th line means the symbol on the grid(the same number means the same symbol on the grid).
 

Output
For each test case, there should be one line in the output.

You should output “Case #x: y”,where x is the case number(starting from 1), and y is a string representing the answer of the question. If there are at least one pair of grids that can be removed together, the y is “Yes”(without quote), else y is “No”.
 

Sample Input
  
  
2 3 3 1 2 1 2 1 2 1 2 1 3 3 1 2 3 2 1 2 3 2 1
 

Sample Output
  
  
Case #1: Yes Case #2: No
Hint
first sample can be explained as below.
解题思路:
连连看的模拟,有相邻的相同方块或用三条线段(水平或垂直)形成的折线相连的相同的方块就Yes,否则No。
#include<iostream>
#include<map>
using namespace std;

int a[35][35];
map<int,int> mp;
int n,m;

bool check(int i,int j)
{
    if(i>=1&&i<=n&&j>=1&&j<=m) return true;
    return false;
}

int main()
{
    int T;
    cin>>T;
    int flag;
    for(int cas=1;cas<=T;cas++)
    {
        flag=0;
        cin>>n>>m;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                cin>>a[i][j];
            }
        }
        mp.clear();
        for(int j=1;j<=m;j++)
        {
            mp[a[1][j]]++;
            if(mp[a[1][j]]>=2)
            {
                cout<<"Case #"<<cas<<": Yes"<<endl;
                flag=1;
            }
            if(flag) break;
        }
        if(flag) continue;
        mp.clear();
        for(int j=1;j<=m;j++)
        {
            mp[a[n][j]]++;
            if(mp[a[n][j]]>=2)
            {
                cout<<"Case #"<<cas<<": Yes"<<endl;
                flag=1;
            }
            if(flag) break;
        }
        if(flag) continue;
        mp.clear();
        for(int i=1;i<=n;i++)
        {
            mp[a[i][1]]++;
            if(mp[a[i][1]]>=2)
            {
                cout<<"Case #"<<cas<<": Yes"<<endl;
                flag=1;
            }
            if(flag) break;
        }
        if(flag) continue;
        mp.clear();
        for(int i=1;i<=n;i++)
        {
            mp[a[i][m]]++;
            if(mp[a[i][m]]>=2)
            {
                cout<<"Case #"<<cas<<": Yes"<<endl;
                flag=1;
            }
            if(flag) break;
        }
        if(flag) continue;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                if(check(i,j+1)&&a[i][j]==a[i][j+1]) flag=1;
                if(check(i+1,j)&&a[i][j]==a[i+1][j]) flag=1;
                if(flag) break;
            }
            if(flag) break;
        }
        if(flag) {cout<<"Case #"<<cas<<": Yes"<<endl;continue;}
        cout<<"Case #"<<cas<<": No"<<endl;
    }
    return 0;
}


最后

以上就是心灵美蜜蜂为你收集整理的2016CCPC东北地区大学生程序设计竞赛-Mr. Frog’s Game Mr. Frog’s Game的全部内容,希望文章能够帮你解决2016CCPC东北地区大学生程序设计竞赛-Mr. Frog’s Game Mr. Frog’s Game所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(35)

评论列表共有 0 条评论

立即
投稿
返回
顶部