我是靠谱客的博主 高挑保温杯,最近开发中收集的这篇文章主要介绍天平问题,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

http://poj.org/problem?id=1837

Balance

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 11238 Accepted: 6991

Description

Gigel has a strange “balance” and he wants to poise it. Actually, the device is different from any other ordinary balance.
It orders two arms of negligible weight and each arm’s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights.
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced.

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device.
It is guaranteed that will exist at least one solution for each test case at the evaluation.

Input

The input has the following structure:
• the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20);
• the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-’ for the left arm and ‘+’ for the right arm);
• on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights’ values.

Output
The output contains the number M representing the number of possibilities to poise the balance.

Sample Input
2 4
-2 3
3 4 5 8

Sample Output
2

Source

Romania OI 2002

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int MAXN=20+5;
int w[MAXN],v[MAXN],n,m;
int dp[MAXN][16005];
int main() {
while(~scanf("%d %d",&n,&m)) {
for(int i=1; i<=n; i++) {
scanf("%d",&w[i]);
}
for(int i=1; i<=m; i++) {
scanf("%d",&v[i]);
}
memset(dp,0,sizeof(dp));
dp[0][8000]=1;
for(int i=1; i<=m; i++) {
for(int j=0; j<=16000; j++) {
if(dp[i-1][j]) {
for(int k=1; k<=n; k++)
dp[i][j+w[k]*v[i]]=dp[i][j+w[k]*v[i]]+dp[i-1][j];//代表着到达这个力矩的次数。表示达到这个力矩的次数时前一次加上已经达到了这个次数的次数
}
}
}
printf("%dn",dp[m][8000]);
}
return 0;
}

最后

以上就是高挑保温杯为你收集整理的天平问题的全部内容,希望文章能够帮你解决天平问题所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(42)

评论列表共有 0 条评论

立即
投稿
返回
顶部