概述
描述 | |
---|---|
知识点 | 字符串 |
运行时间限制 | 10M |
内存限制 | 128 |
输入 | 输入一个string型基因序列,和int型子串的长度 |
输出 | 找出GC比例最高的字串 |
样例输入 | AACTGTGCACGACCTGA 5 |
样例输出 | GCACG |
/*找出一个字符串中,找出指定长度的子字符串中,G和C这两个字符总共出现最多的子串,如果出现次数相同,取最先出现的字串
* */
import java.util.Scanner;
public class Main{
public static void main(String[] args){
Scanner sc = new Scanner(System.in);
String input = sc.next().trim();
int n = sc.nextInt();
sc.close();
int max = 0;
String result = null;
for(int i = 0; i < input.length()-5; i++){
//每次截取制定长度的字串进行遍历
String temp = input.substring(i, i+n);
int length = 0;
for(int j = 0; j < n; j++){
if(temp.charAt(j) == 'G' || temp.charAt(j) == 'C')
length++;
}
if(max < length){
max = length;
result = temp;
}
}
System.out.println(result);
}
}
最后
以上就是称心黑裤为你收集整理的华为OJ 初级:DNA序列的全部内容,希望文章能够帮你解决华为OJ 初级:DNA序列所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复