概述
DNA Sorting
Time Limit : 2000/1000ms (Java/Other) Memory Limit : 65536/32768K (Java/Other)
Total Submission(s) : Accepted Submission(s) :
Problem Description
One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be--exactly the reverse of sorted).
You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.
Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.
Output
Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. If two or more strings are equally sorted, list them in the same order they are in the input file.
Sample Input
1
10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT
Sample Output
CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA
题目不难,就是意思难懂,多看看翻译读懂题,这是字符串组的排序,我们学了数组排序,像这种字符串组要怎么排序呢?其实是一样的,数有赋值,字符串有复制,用冒泡的原理,我们同样可以将一组字符串进行排序。这里还要求懂得使用二维字符串,并懂得怎么使用每一行的字符串。
代码如下:
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
int main()
{
int T,a,b,i,j,t,o,n[51];//这里用到了一个数组,我会将数组与字符串进行绑定
char m[51][101],l[101];
scanf("%d",&T);
while(T--)
{
memset(n,0,51);
scanf("%d%d",&a,&b);
for(i=0;i<b;i++)
scanf("%s",&m[i]);
for(i=0;i<b;i++)
for(j=0;j<a-1;j++)
for(o=j+1;o<a;o++)
{
if(m[i][j]>m[i][o])
n[i]++;//理解题目,这里再算一行字符串的数值,并绑定数组
}
for(i=0;i<b-1;i++)
for(j=0;j<b-i-1;j++)
if(n[j]>n[j+1])
{
t=n[j];
n[j]=n[j+1];
n[j+1]=t;
strcpy(l,m[j]);
strcpy(m[j],m[j+1]);
strcpy(m[j+1],l);
}//冒泡排序,将数组和字符串组同时进行排序
for(i=0;i<b;i++)
{
//printf("%dn",n[i]);
puts(m[i]);
}
}
return 0;
}
最后
以上就是大方溪流为你收集整理的杭电 1379 DNA Sorting的全部内容,希望文章能够帮你解决杭电 1379 DNA Sorting所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复