我是靠谱客的博主 高兴犀牛,最近开发中收集的这篇文章主要介绍hdu1379DNA Sorting,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
One measure of unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequenceDAABEC”, this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence AACEDGG'' has only one inversion (E and D)--it is nearly sorted--while the sequenceZWQM” has 6 inversions (it is as unsorted as can be–exactly the reverse of sorted).

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of sortedness'', frommost sorted” to “least sorted”. All the strings are of the same length.

This problem contains multiple test cases!

The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.

The output format consists of N output blocks. There is a blank line between output blocks.

Input
The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (1 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output
Output the list of input strings, arranged from most sorted'' toleast sorted”. If two or more strings are equally sorted, list them in the same order they are in the input file.

Sample Input

1

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

分析:简单水题,数据很小。唯一要注意的是,格式问题,我pe了一次。

#include<iostream>
#include<cstring>
#include<string>
#include<algorithm>
#include<cmath>
using namespace std;
int n,m;
struct p{
int id;
int ve;
char s[55];
}vis[105];
bool cmp1(p a,p b)
{
if(a.ve !=b.ve )
return a.ve<b.ve;
else
return a.id <b.id ;
}
void slove()
{
for(int i=0;i<m;i++)
{
vis[i].ve=0,vis[i].id=i;
for(int j=n-1;j>=0;j--)
{
for(int k=j-1;k>=0;k--)
{
if(vis[i].s[j]<vis[i].s[k])
vis[i].ve++;
}
}
}
}
int main()
{
int t;
while(t--)
{
getchar();
scanf("%d %d",&n,&m);
for(int i=0;i<m;i++)
{
scanf("%s",&vis[i].s );
}
slove();
sort(vis,vis+m,cmp1);
for(int i=0;i<m;i++)
{
cout<<vis[i].s<<endl;
}
}
return 0;
} 

最后

以上就是高兴犀牛为你收集整理的hdu1379DNA Sorting的全部内容,希望文章能够帮你解决hdu1379DNA Sorting所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(69)

评论列表共有 0 条评论

立即
投稿
返回
顶部