我是靠谱客的博主 洁净刺猬,最近开发中收集的这篇文章主要介绍Hdu-1867 A + B for you againA + B for you again,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

A + B for you again

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6027    Accepted Submission(s): 1493


Problem Description
Generally speaking, there are a lot of problems about strings processing. Now you encounter another such problem. If you get two strings, such as “asdf” and “sdfg”, the result of the addition between them is “asdfg”, for “sdf” is the tail substring of “asdf” and the head substring of the “sdfg” . However, the result comes as “asdfghjk”, when you have to add “asdf” and “ghjk” and guarantee the shortest string first, then the minimum lexicographic second, the same rules for other additions.
 

Input
For each case, there are two strings (the chars selected just form ‘a’ to ‘z’) for you, and each length of theirs won’t exceed 10^5 and won’t be empty.
 

Output
Print the ultimate string by the book.
 

Sample Input
  
  
asdf sdfg asdf ghjk
 

Sample Output
  
  
asdfg asdfghjk
 

Author
Wang Ye
 

Source
2008杭电集训队选拔赛——热身赛
 

Recommend
lcy
 

分析:两次KMP

#include <cstdio>
#include <string>
#include <cstring>
#include <iostream>
#define max(a,b) a > b ? a : b
using namespace std;
char a[100005],b[100005],s1[200005],s2[200005];
int Next[100005];
void got(char a[],char b[],char c[])
{
	int n = strlen(a),m = strlen(b);
	memset(Next,0,sizeof(Next));
	int now = Next[0] = -1;
	for(int i = 1;i < m;i++)
	{
		while(now >= 0 && b[now+1] != b[i]) now = Next[now];
		if(b[now+1] == b[i]) now++;
		Next[i] = now;
	}
	now = -1;
	for(int i = max(0,n-m);i < n;i++)
	{
		while(now >= 0 && b[now+1] != a[i]) now = Next[now];
		if(b[now+1] == a[i]) now++;
	}
	memset(c,0,sizeof(c));  
	for(int i = 0;i < n;i++) c[i] = a[i];
	int l = n - 1;
	for(int i = now + 1;i <= m;i++) c[++l] = b[i];
}
int main()
{
	cin.sync_with_stdio(false);
	while(cin>>a>>b)
	{
		got(a,b,s1);
		got(b,a,s2);
		if(strlen(s1) > strlen(s2) || (strlen(s1) == strlen(s2) && strcmp(s1,s2) > 0)) cout<<s2<<endl;
		else cout<<s1<<endl;
	}
}


最后

以上就是洁净刺猬为你收集整理的Hdu-1867 A + B for you againA + B for you again的全部内容,希望文章能够帮你解决Hdu-1867 A + B for you againA + B for you again所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(51)

评论列表共有 0 条评论

立即
投稿
返回
顶部