我是靠谱客的博主 妩媚老虎,最近开发中收集的这篇文章主要介绍HDU2057-A + B Again,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

HDU2057-A + B Again

题目:
There must be many A + B problems in our HDOJ , now a new one is coming.
Give you two hexadecimal integers , your task is to calculate the sum of them,and print it in hexadecimal too.
Easy ? AC it !
Input
The input contains several test cases, please process to the end of the file.
Each case consists of two hexadecimal integers A and B in a line seperated by a blank.
The length of A and B is less than 15.
Output
For each test case,print the sum of A and B in hexadecimal in one line.
Sample Input
+A -A
+1A 12
1A -9
-1A -12
1A -AA
Sample Output
0
2C
11
-2C
-90

#include<bits/stdc++.h>
using namespace std;

int main()
{
    long long a,b;
    while(~scanf("%llX%llX",&a,&b))
    {
        if(a + b < 0)
        {
            a = -a;
            b = -b;
            cout << "-";
        }
        printf("%llXn",a + b);
    }
    return 0;
}

需要注意的是如果用long long,输入和输入时都需要写成 %llX ,%x和%X分别对应十六进制中字母小写和字母大写

另外如果相加出现负数的时候需要在前面手动加“-”,然后把a,b分别取反,如果不加就会跳出一堆数字。。。。

最后

以上就是妩媚老虎为你收集整理的HDU2057-A + B Again的全部内容,希望文章能够帮你解决HDU2057-A + B Again所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部