我是靠谱客的博主 喜悦小鸭子,最近开发中收集的这篇文章主要介绍The Pilots Brothers' refrigerator高效贪心算法     DescriptionInput      Output      Sample InputSample Output,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

     Description

The game “The Pilots Brothers: following the stripy elephant” has a quest where a player needs to open a refrigerator.

There are 16 handles on the refrigerator door. Every handle can be in one of two states: open or closed. The refrigerator is open only when all handles are open. The handles are represented as a matrix 4х4. You can change the state of a handle in any location [i, j] (1 ≤ i, j ≤ 4). However, this also changes states of all handles in row i and all handles in column j.

The task is to determine the minimum number of handle switching necessary to open the refrigerator.

Input

The input contains four lines. Each of the four lines contains four characters describing the initial state of appropriate handles. A symbol “+” means that the handle is in closed state, whereas the symbol “−” means “open”. At least one of the handles is initially closed.

      Output

The first line of the input contains N – the minimum number of switching. The rest N lines describe switching sequence. Each of the lines contains a row number and a column number of the matrix separated by one or more spaces. If there are several solutions, you may give any one of them.

      Sample Input

-+--
----
----
-+--

Sample Output

6
1 1
1 3
1 4
4 1
4 3
4 4

高效贪心算法 AC代码

#include<iostream>
#include<cstring>
#include<cstdio>
#include<queue>
using namespace std;
int num=0x3f3f3f3f;
int a[10][10],b[10][10],flag;
int fanzhuan(int x,int y)
{
a[x][y]=!a[x][y];
for(int i=0; i<4; i++)
a[x][i]=!a[x][i];
for(int j=0; j<4; j++)
a[j][y]=!a[j][y];
}
int panduan()
{
for(int i=0; i<4; i++)
for(int j=0; j<4; j++)
if(!a[i][j])
return 0;
return 1;
}
struct node
{
int a,b;
} p[20];
void DFS(int x,int y,int ans)//将所有的num步的情况都跑一遍判断是否有符合的
{
if(num==ans)
{
flag=panduan();
return ;
}
if(flag||x>=4||y>=4)
return ;
int fy=(y+1)%4;
//按行移动的
int fx=x+(y+1)/4;
fanzhuan(x,y);
DFS(fx,fy,ans+1);
p[ans].a=x;
p[ans].b=y;
fanzhuan(x,y);//原路返回
DFS(fx,fy,ans);
}
int main()
{
string s[4];
while(cin>>s[0])
{
for(int i=1; i<4; i++)
cin>>s[i];
for(int i=0; i<4; i++)
for(int j=0; j<4; j++)//格式转换
if(s[i][j]=='+')
a[i][j]=0;
else
a[i][j]=1;
flag=0;
for(int i=0; i<=16; i++)//枚举
{
num=i;
DFS(0,0,0);
if(flag)
break;
}
cout<<num<<endl;
for(int i=0; i<num; i++)
cout<<p[i].a+1<<" "<<p[i].b+1<<endl;
}
} 




最后

以上就是喜悦小鸭子为你收集整理的The Pilots Brothers' refrigerator高效贪心算法     DescriptionInput      Output      Sample InputSample Output的全部内容,希望文章能够帮你解决The Pilots Brothers' refrigerator高效贪心算法     DescriptionInput      Output      Sample InputSample Output所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部