我是靠谱客的博主 傲娇月饼,最近开发中收集的这篇文章主要介绍HDOJ 1220 Cube【数学推理】 Cube,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Cube

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1734    Accepted Submission(s): 1379


Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.

Process to the end of file.
 

Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
 

Output
For each test case, you should output the number of pairs that was described above in one line.
 

Sample Input
1 2 3
 

Sample Output
0 16 297
Hint
Hint
The results will not exceed int type.

恩,题意大致是,边长为N的立方体,要切成N*N*N个边长为1的小立方体,两个小立方体的公共顶点个数不超过2的这样的立方体对共有多少对。切割之后立方体之间公共顶点的个数只有0,1,2,4,这几种情况,用总的减去公共顶点为4的即可。总的为n*n*n*(n*n*n-1)/2公共顶点为4的要分别算,下面代码里有计算公式。


#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int main()
{
int n;
__int64 s,t;
while(~scanf("%d",&n))
{
if(n==1)
{
printf("0n");
continue;
}
s=n*n*n*(n*n*n-1)/2;
t=8*3/2+(n-2)*4*3*4/2+(n-2)*(n-2)*6*5/2+(n-2)*(n-2)*(n-2)*6/2;
s=s-t;
printf("%I64dn",s);
}
return 0;
}


最后

以上就是傲娇月饼为你收集整理的HDOJ 1220 Cube【数学推理】 Cube的全部内容,希望文章能够帮你解决HDOJ 1220 Cube【数学推理】 Cube所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部