Cube
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1721 Accepted Submission(s): 1366
Problem Description
Cowl is good at solving math problems. One day a friend asked him such a question: You are given a cube whose edge length is N, it is cut by the planes that was paralleled to its side planes into N * N * N unit cubes. Two unit cubes may have no common points or two common points or four common points. Your job is to calculate how many pairs of unit cubes that have no more than two common points.
Process to the end of file.
Process to the end of file.
Input
There will be many test cases. Each test case will only give the edge length N of a cube in one line. N is a positive integer(1<=N<=30).
Output
For each test case, you should output the number of pairs that was described above in one line.
Sample Input
1 2 3
Sample Output
0 16 297The results will not exceed int type.HintHint
Author
Gao Bo
Source
杭州电子科技大学第三届程序设计大赛
解题思路:
题目大意就是将一个大的正方体,切成一个一个的单位正方体,问这些正方体中有多少对(注意是对:也就是两个)是公共顶点小于两个的。
我们知道从这些单位正方体中找出两个的情况是多少
n
*
n
*
n
*(
n
*
n
*
n
-1
)/
2,又因为公共顶点只可能是0 1 2 4,所以我们找出公共点是4的减去对数就行了。
#include<stdio.h>
#include<string.h>
#include<math.h>
using namespace std;
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
if(n==1)
{
printf("0n");
continue;
}
printf("%dn",n*n*n*(n*n*n-1)/2-3*n*n*(n-1));
}
return 0;
}
最后
以上就是魁梧星星最近收集整理的关于HDOJ 1220-Cube【数学推理】Cube的全部内容,更多相关HDOJ内容请搜索靠谱客的其他文章。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复