我是靠谱客的博主 谨慎小蚂蚁,最近开发中收集的这篇文章主要介绍HDU 3584 Cube,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description

Given an N*N*N cube A, whose elements are either 0 or 1. A[i, j, k] means the number in the i-th row , j-th column and k-th layer. Initially we have A[i, j, k] = 0 (1 <= i, j, k <= N). 
We define two operations, 1: “Not” operation that we change the A[i, j, k]=!A[i, j, k]. that means we change A[i, j, k] from 0->1,or 1->0. (x1<=i<=x2,y1<=j<=y2,z1<=k<=z2).
0: “Query” operation we want to get the value of A[i, j, k].

Input

Multi-cases.
First line contains N and M, M lines follow indicating the operation below.
Each operation contains an X, the type of operation. 1: “Not” operation and 0: “Query” operation.
If X is 1, following x1, y1, z1, x2, y2, z2.
If X is 0, following x, y, z.

Output

For each query output A[x, y, z] in one line. (1<=n<=100 sum of m <=10000)

Sample Input

2 5
1 1 1 1  1 1 1
0 1 1 1
1 1 1 1  2 2 2
0 1 1 1
0 2 2 2

Sample Output

1
0

1

每次都是一段区间的反转操作,问一个点的状态。

通过三维树状数组实现,对于每个区间操作稍作转化。

一维区间的[l,r]反转可以看做是a[l]+1和a[r+1]-1,树状数组求和的性质便完成了区间的操作。

三维的只要通过容斥原理就可以了。

#include<iostream>  
#include<algorithm>
#include<math.h>
#include<cstdio>
#include<string>
#include<string.h>
using namespace std;
const int maxn = 105;
const int low(int x){ return (x&-x); }
int f[maxn][maxn][maxn], u, n, m, x, y, z, i, j, k;

void add(int x, int y, int z, int w)
{
	for (int i = x; i <= n; i = i + low(i))
		for (int j = y; j <= n; j = j + low(j))
			for (int k = z; k <= n; k = k + low(k)) f[i][j][k] += w;
}

int sum(int x, int y, int z)
{
	int tot = 0;
	for (int i = x; i > 0; i = i - low(i))
		for (int j = y; j > 0; j = j - low(j))
			for (int k = z; k > 0; k = k - low(k)) tot += f[i][j][k];
	return tot;
}

int main(){
	while (~scanf("%d%d", &n, &m))
	{
		memset(f, 0, sizeof(f));
		while (m--)
		{
			scanf("%d%d%d%d", &u, &x, &y, &z);
			if (!u) printf("%dn", sum(x, y, z) & 1);
			else {
				scanf("%d%d%d", &i, &j, &k);
				add(x, y, z, 1);
				add(x, y, k + 1, 1);
				add(x, j + 1, z, 1);
				add(i + 1, y, z, 1);
				add(x, j + 1, k + 1, 1);
				add(i + 1, j + 1, z, 1);
				add(i + 1, y, k + 1, 1);
				add(i + 1, j + 1, k + 1, 1);
			}
		}
	}
	return 0;
}


最后

以上就是谨慎小蚂蚁为你收集整理的HDU 3584 Cube的全部内容,希望文章能够帮你解决HDU 3584 Cube所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(48)

评论列表共有 0 条评论

立即
投稿
返回
顶部