Description
An addition chain for n is an integer sequence with the following four properties:
a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj
You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.
Input
The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.
Sample Input
5
7
12
15
77
0
Sample Output
1 2 4 5
1 2 4 6 7
1 2 4 8 12
1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
题目思想:依次搜索每个位置k,枚举i、j,同时采用迭代加深的方式,从一开始限制搜索深度
#include<iostream>
#include<cstdio>
using namespace std;
int deep,n,res[21];
bool dfs(int cnt,int num){
if(cnt==deep){//迭代层次为deep,如果到了最深搜索层仍未找到答案,回溯。
if(num==n) return true;
return false;
}
for(int i=0;i<=cnt;i++){//这里可以看出,可能1~deep-1会重复搜索,但是相对于分支数目较多,层数增长,指数增长,效率比较高
num+=res[i];
if(num<=n){
res[cnt+1]=num;//因为包含关系,x[k]=x[i]+x[j] 所以每次都用最大的加,同时提高效率
if(dfs(cnt+1,num)) return true;
}
num-=res[i];
}
return false;
}
int main()
{
while(scanf("%d",&n),n){
if(n==1) {cout<<"1"<<endl;continue;}
deep=1;res[0]=1;
while(true){
if(dfs(0,1)) break;
deep++;
}
for(int i=0;i<=deep;i++){
cout<<res[i]<<" ";
}
cout<<endl;
}
}
最后
以上就是欣喜太阳最近收集整理的关于poj2248 Addtion Chains(迭代加深)的全部内容,更多相关poj2248内容请搜索靠谱客的其他文章。
发表评论 取消回复