我是靠谱客的博主 聪慧糖豆,最近开发中收集的这篇文章主要介绍Addition Chains,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Addition Chains

An addition chain for n is an integer sequence <a0, a1,a2,…,am> with the following four properties:

a0 = 1
am = n
a0 < a1 < a2 < … < am-1 < am
For each k (1 <= k <= m) there exist two (not necessarily different) integers i and j (0 <= i, j <= k-1) with ak = ai + aj

You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.

For example, <1, 2, 3, 5> and <1, 2, 4, 5> are both valid solutions when you are asked for an addition chain for 5.

Input

The input will contain one or more test cases. Each test case consists of one line containing one integer n (1 <= n <= 100). Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.

Sample Input

 5
 7
 12
 15
 77
 0 

Sample Output

 1 2 4 5
 1 2 4 6 7
 1 2 4 8 12
 1 2 4 5 10 15
 1 2 4 8 9 17 34 68 77

题意:
给你一个数,问你从1开始,最少几个数能加到这个数,其中的一个数(除了1)必须能被其中的两个数相加得到。
思路:既然要最少的,那么这些数越大越好,所以咱们可以倒着搜。
代码:

#include<stdio.h>
#include<string.h>
int a[110];
int s,c[110],n;
void dfs(int x,int b)
{
    if(x>n||b>=s)
        return;
    if(x==n&&b<s)
    {
        s=b;
        for(int i=0; i<s; i++)
            c[i]=a[i];
        return;
    }
    for(int i=b-1; i>=0; i--)
    {
        a[b]=x+a[i];
        dfs(a[b],b+1);
        a[b]=0;
    }
    return;
}
int main()
{
    while(~scanf("%d",&n),n)
    {
        memset(a,0,sizeof(a));
        memset(c,0,sizeof(c));
        s=110;
        if(n==1)
        {
            printf("1n");
            continue;
        }
        a[0]=1,a[1]=2;
        dfs(2,2);
        printf("%d",c[0]);
        for(int i=1;i<s;i++)
            printf(" %d",c[i]);
        printf("n");
    }
    return 0;
}

最后

以上就是聪慧糖豆为你收集整理的Addition Chains的全部内容,希望文章能够帮你解决Addition Chains所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部