概述
描述An addition chain for n is an integer sequence with the following four properties:
- a0 = 1
- am = n
- a0 < a1 < a2 < ... < am-1 < am
- For each k (1<=k<=m) there exist two (not necessarily different) integers i and j (0<=i, j<=k-1) with ak=ai+aj
You are given an integer n. Your job is to construct an addition chain for n with minimal length. If there is more than one such sequence, any one is acceptable.
For example, <1,2,3,5> and <1,2,4,5> are both valid solutions when you are asked for an addition chain for 5.输入The input will contain one or more test cases. Each test case consists of one line containing one integer n (1<=n<=100). Input is terminated by a value of zero (0) for n.输出For each test case, print one line containing the required integer sequence. Separate the numbers by one blank.
Hint: The problem is a little time-critical, so use proper break conditions where necessary to reduce the search space.
样例输入
5 7 12 15 77 0样例输出
1 2 4 5 1 2 4 6 7 1 2 4 8 12 1 2 4 5 10 15
1 2 4 8 9 17 34 68 77
迭代加深的模板题,枚举深度就ok了
迭代加深搜索:当搜索树随着层次增长很快,并且我们能推出答案在较浅层时;
#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cmath>
#include<queue>
#include<cstring>
using namespace std;
#define ll long long
typedef pair<int,int>P;
const int len=12;
int n;
int de;
int ans[len];
int vis[1005];
bool dfs(int d)
{
if(d>de)return false;
if(ans[d]>n)return false;
if(ans[d]<=ans[d-1])return false;
if(ans[d]==n)return true;
for(int i=d;i>=1;--i)
{
for(int j=d;j>=i;--j)
{
ans[d+1]=ans[i]+ans[j];
if(vis[ans[d+1]]==0)
{
int sum=ans[d+1];
for(int k=d+1;k<=de;++k)
sum*=2;
if(sum<n)continue;
vis[ans[d+1]]=1;
if(dfs(d+1))return true;
vis[ans[d+1]]=0;
}
}
}
return false;
}
int main()
{
while(scanf("%d",&n)&&n)
{
ans[0]=0;
ans[1]=1;
int i;
for(i=1;i<=10;++i)
{
de=i;
memset(vis,0,sizeof(vis));
vis[1]=1;
if(dfs(1))break;
}
for(int j=1;j<i;++j)
printf("%d ",ans[j]);
cout<<ans[i]<<endl;
}
}
最后
以上就是潇洒小兔子为你收集整理的poj 2248 Addition Chains 迭代加深搜索的全部内容,希望文章能够帮你解决poj 2248 Addition Chains 迭代加深搜索所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复