/*
中文题目 花
题目大意:n种花,m块钱,求解最多可以买多少朵花
解题思路:排序,找出最便宜的花,在用总价钱除以最便宜的单价
解题人:lingnichong
解题时间:2014-09-03 22:20:34
解题体会:简单题
*/
Flowers
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2779 Accepted Submission(s): 1856
Problem Description
As you know, Gardon trid hard for his love-letter, and now he's spending too much time on choosing flowers for Angel.
When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers.
"How can I choose!" Gardon shouted out.
Finally, Gardon-- a no-EQ man decided to buy flowers as many as possible.
Can you compute how many flowers Gardon can buy at most?
When Gardon entered the flower shop, he was frightened and dazed by thousands kinds of flowers.
"How can I choose!" Gardon shouted out.
Finally, Gardon-- a no-EQ man decided to buy flowers as many as possible.
Can you compute how many flowers Gardon can buy at most?
Input
Input have serveral test cases. Each case has two lines.
The first line contains two integers: N and M. M means how much money Gardon have.
N integers following, means the prices of differnt flowers.
The first line contains two integers: N and M. M means how much money Gardon have.
N integers following, means the prices of differnt flowers.
Output
For each case, print how many flowers Gardon can buy at most.
You may firmly assume the number of each kind of flower is enough.
You may firmly assume the number of each kind of flower is enough.
Sample Input
2 5 2 3
Sample Output
2Gardon can buy 5=2+3,at most 2 flower, but he cannot buy 3 flower with 5 yuan.HintHint
#include<stdio.h>
#include<algorithm>
using namespace std;
int a[10000];
int main()
{
int n,m;
int i,j;
while(~scanf("%d%d",&n,&m))
{
for(i=0;i<n;i++)
scanf("%d",&a[i]);
sort(a,a+n);
printf("%dn",m/a[0]);
}
return 0;
}
最后
以上就是暴躁大米最近收集整理的关于HDU 1587 Flowers【简单题】 Flowers的全部内容,更多相关HDU内容请搜索靠谱客的其他文章。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复