我是靠谱客的博主 壮观网络,这篇文章主要介绍HDU - 5918 Sequence I,现在分享给大家,希望可以做个参考。

Mr. Frog has two sequences  a1,a2,,an a1,a2,⋯,an and  b1,b2,,bm b1,b2,⋯,bm and a number p. He wants to know the number of positions q such that sequence  b1,b2,,bm b1,b2,⋯,bm is exactly the sequence  aq,aq+p,aq+2p,,aq+(m1)p aq,aq+p,aq+2p,⋯,aq+(m−1)p where  q+(m1)pn q+(m−1)p≤n and  q1 q≥1.
Input
The first line contains only one integer  T100 T≤100, which indicates the number of test cases. 

Each test case contains three lines. 

The first line contains three space-separated integers  1n106,1m106 1≤n≤106,1≤m≤106 and  1p106 1≤p≤106

The second line contains n integers  a1,a2,,an(1ai109) a1,a2,⋯,an(1≤ai≤109)

the third line contains m integers  b1,b2,,bm(1bi109) b1,b2,⋯,bm(1≤bi≤109).
Output
For each test case, output one line “Case #x: y”, where x is the case number (starting from 1) and y is the number of valid q’s.
Sample Input
复制代码
1
2
3
4
5
6
7
2 6 3 1 1 2 3 1 2 3 1 2 3 6 3 2 1 3 2 2 3 1 1 2 3
Sample Output
复制代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
Case #1: 2

Case #2: 1

有规律的暴力,直接求答案:

复制代码
#include <stdio.h>
const int maxn = 1e6+5;
int a[maxn];
int b[maxn];
int main() {
	int N;
	int n , m , p;
	scanf("%d",&N);
	int M = N;
	while(N--) {
		int sum = 0 , flag;
		scanf("%d %d %d",&n, &m, &p);
		for(int i = 0; i < n; i++)
		scanf("%d",&a[i]);
		for(int i = 0; i < m; i++)
		scanf("%d",&b[i]);
		for(int j = 0; j <= (n - m*p + p - 1); j++) {
			if(a[j] == b[0]) {
				flag = 0;
				for(int k = 1; k < m; k++) {
					if(b[k] != a[j + k*p]) {
						flag = 1;
						break;
					}
				}	
				if(flag == 0)
				sum++;
			}
		}
		printf("Case #%d: %dn",M - N, sum);
	}
	return 0;
}


最后

以上就是壮观网络最近收集整理的关于HDU - 5918 Sequence I的全部内容,更多相关HDU内容请搜索靠谱客的其他文章。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(73)

评论列表共有 0 条评论

立即
投稿
返回
顶部