概述
题目描述
输入3个整数,输出它们的1次幂、2次幂和3次幂。
输入
输入3整数,用空格隔开。
输出
输出3行,每行3个整数,分别是它们的1次幂、2次幂和3次幂,每个整数占9列,不足9列左对齐。
样例输入 Copy
1 5 100
样例输出 Copy
1 1 1
5 25 125
100 10000 1000000
import java.util.*;
public class Main{
public static void main(String[]args)
{
Scanner input=new Scanner(System.in);
int a=input.nextInt();
int b=input.nextInt();
int c=input.nextInt();
System.out.printf("%-9d%-9d%-9dn",a,a*a,a*a*a);
System.out.printf("%-9d%-9d%-9dn",b,b*b,b*b*b);
System.out.printf("%-9d%-9d%-9dn",c,c*c,c*c*c);
}
}
!
print输出且不换行;
println输出换行;
两者输出多个结果用“+”连接;
printf输出类似c的printf
!新增了C++:
#include<iostream>
#include<math.h>
#include<iomanip>
using namespace std;
int main() {
int x,y,z;
cin >> x>>y>>z;
cout.setf(ios::left); //设置对齐方式为left
cout.width(9);
//cout.fill(' '); //设置填充字符
cout << x <<setw(9)<< pow(x, 2) << setw(9) << fixed << setprecision(0) << pow(x, 3) << endl;
cout.width(9);
cout << y << setw(9) << pow(y, 2) << setw(9) << fixed << setprecision(0) << pow(y, 3) << endl;
cout.width(9);
cout << z << setw(9) << pow(z, 2) << setw(9) << fixed << setprecision(0) << pow(z, 3) << endl;
return 0;
}
最后
以上就是鲜艳毛豆为你收集整理的ZZULIOJ 1005 整数幂(JAVA&C++)题目描述!的全部内容,希望文章能够帮你解决ZZULIOJ 1005 整数幂(JAVA&C++)题目描述!所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复