我是靠谱客的博主 坦率铃铛,最近开发中收集的这篇文章主要介绍HDU 5583 Kingdom of Black and White(依旧是暴力)——2015ACM/ICPC亚洲区上海站 Kingdom of Black and White,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Kingdom of Black and White

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
In the Kingdom of Black and White (KBW), there are two kinds of frogs: black frog and white frog.

Now  N  frogs are standing in a line, some of them are black, the others are white. The total strength of those frogs are calculated by dividing the line into minimum parts, each part should still be continuous, and can only contain one kind of frog. Then the strength is the sum of the squared length for each part.

However, an old, evil witch comes, and tells the frogs that she will change the color of  at most one frog and thus the strength of those frogs might change.

The frogs wonder the  maximum possible strength after the witch finishes her job.
 

Input
First line contains an integer  T , which indicates the number of test cases.

Every test case only contains a string with length  N , including only  0  (representing
a black frog) and  1  (representing a white frog).

  1T50 .

 for 60% data,  1N1000 .

 for 100% data,  1N105 .

 the string only contains 0 and 1.
 

Output
For every test case, you should output " Case #x: y",where  x  indicates the case number and counts from  1  and  y  is the answer.
 

Sample Input
  
  
2 000011 0101
 

Sample Output
  
  
Case #1: 26 Case #2: 10
 
/*********************************************************************/

题意:给你一个01字符串,要求最多改变一个字符(即0->1或1->0),使相邻相同字符的平方和最大

比如说字符串000  11  0

                        3    2     1

平方和为3*3+2*2+1*1=14

解题思路:其实此题还是暴力求解的,首先我们把相邻相同的字符分块,即上述的3 2 1,然后对于第i个分块与第i+1个分块,枚举(第i个分块字符个数+1和第i+1个分块字符个数-1)的情况与(第i个分块字符个数-1和第i+1个分块字符个数+1)的情况,需注意的是当第i+1个分块若只有一个字符,那么第i个分块、第i+1个分块、第i+2个分块会合成一个分块,同理,当第i个分块只有一个字符时,第i-1个分块、第i个分块、第i+1个分块会合成一个分块,我们更新最大值就可以了

#pragma comment(linker, "/STACK:1024000000,1024000000")
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<queue>
#include<stack>
#include<math.h>
#include<vector>
#include<map>
#include<set>
#include<stdlib.h>
#include<cmath>
#include<string>
#include<algorithm>
#include<iostream>
#define exp 1e-10
#define MAX(a,b) ((a)>(b)?(a):(b))
using namespace std;
const int N = 100005;
const int M = 2010;
const int inf = 2147483647;
const int mod = 2009;
__int64 s[N];
char num[N];
int main()
{ 
    int t,i,j,p=1;
    __int64 ans,Max,k;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%s",num);
        for(ans=0,j=1,k=1,i=1;num[i]!='';i++)
            if(num[i]!=num[i-1])
                s[j++]=k,ans+=k*k,k=1;
            else
                k++;
        s[j++]=k;ans+=k*k;s[j++]=0;Max=ans;
        //printf("%I64dn",Max);
        for(i=1;i<j-2;i++)
        {
            //printf("%d %dn",s[i],s[i+1]);
            if(s[i+1]==1)
                Max=max(Max,ans-s[i]*s[i]-s[i+1]*s[i+1]-s[i+2]*s[i+2]+(s[i]+s[i+1]+s[i+2])*(s[i]+s[i+1]+s[i+2]));
            else
                Max=max(Max,ans-s[i]*s[i]-s[i+1]*s[i+1]+(s[i]+1)*(s[i]+1)+(s[i+1]-1)*(s[i+1]-1));
            //printf("###%d %I64dn",i,Max);
            if(s[i]==1)
                Max=max(Max,ans-s[i]*s[i]-s[i+1]*s[i+1]-s[i-1]*s[i-1]+(s[i]+s[i+1]+s[i-1])*(s[i]+s[i+1]+s[i-1]));
            else
                Max=max(Max,ans-s[i]*s[i]-s[i+1]*s[i+1]+(s[i]-1)*(s[i]-1)+(s[i+1]+1)*(s[i+1]+1));
            //printf("@@@@%d %I64dn",i,Max);
        }
        printf("Case #%d: %I64dn",p++,Max);    
    }
    return 0; 
}
菜鸟成长记

最后

以上就是坦率铃铛为你收集整理的HDU 5583 Kingdom of Black and White(依旧是暴力)——2015ACM/ICPC亚洲区上海站 Kingdom of Black and White的全部内容,希望文章能够帮你解决HDU 5583 Kingdom of Black and White(依旧是暴力)——2015ACM/ICPC亚洲区上海站 Kingdom of Black and White所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(73)

评论列表共有 0 条评论

立即
投稿
返回
顶部