我是靠谱客的博主 开朗背包,最近开发中收集的这篇文章主要介绍2014ACM/ICPC亚洲区北京站-B - Black And White,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

HDU - 5113

In mathematics, the four color theorem, or the four color map theorem, states that, given any separation of a plane into contiguous regions, producing a figure called a map, no more than four colors are required to color the regions of the map so that no two adjacent regions have the same color. 
— Wikipedia, the free encyclopedia 

In this problem, you have to solve the 4-color problem. Hey, I’m just joking. 

You are asked to solve a similar problem: 

Color an N × M chessboard with K colors numbered from 1 to K such that no two adjacent cells have the same color (two cells are adjacent if they share an edge). The i-th color should be used in exactly c i cells. 

Matt hopes you can tell him a possible coloring.

Input

The first line contains only one integer T (1 ≤ T ≤ 5000), which indicates the number of test cases. 

For each test case, the first line contains three integers: N, M, K (0 < N, M ≤ 5, 0 < K ≤ N × M ). 

The second line contains K integers c i (c i > 0), denoting the number of cells where the i-th color should be used. 

It’s guaranteed that c 1 + c 2 + · · · + c K = N × M . 

Output

For each test case, the first line contains “Case #x:”, where x is the case number (starting from 1). 

In the second line, output “NO” if there is no coloring satisfying the requirements. Otherwise, output “YES” in one line. Each of the following N lines contains M numbers seperated by single whitespace, denoting the color of the cells. 

If there are multiple solutions, output any of them.

Sample Input

4
1 5 2
4 1
3 3 4
1 2 2 4
2 3 3
2 2 2
3 2 3
2 2 2

Sample Output

Case #1:
NO
Case #2:
YES
4 3 4
2 1 2
4 3 4
Case #3:
YES
1 2 3
2 3 1
Case #4:
YES
1 2
2 3
3 1

dfs+剪枝

剪枝方法:若剩余空格数为 res , 对于每种颜色的数量t ,都要满足 (res+1)> t 。 

#include<bits/stdc++.h>
using namespace std;
const int maxn=15;
int ans[maxn][maxn],a[maxn],n,m,k,flag,t,xx,yy;
void input()
{
flag=0;
memset(ans,0,sizeof(ans));
scanf("%d %d %d",&n,&m,&k);
for(int i=1; i<=k; i++)
scanf("%d",&a[i]);
}
void dfs(int x,int y,int res)
{
if(res==0) flag=1;
if(flag) return ;
for(int i=1;i<=k;i++)
if((res+1)/2<a[i]) return;
for(int i=1;i<=k;i++)
{
if(a[i]&&ans[x-1][y]!=i&&ans[x][y-1]!=i)
{
ans[x][y]=i,a[i]--;
if(y+1>m)
xx=x+1,yy=1;
else
xx=x,yy=y+1;
dfs(xx,yy,res-1);
if(flag)
return ;
ans[x][y]=0,a[i]++;
}
}
}
int main()
{
int T;
scanf("%d",&T);
for(int co=1; co<=T; co++)
{
input();
printf("Case #%d:n",co);
dfs(1,1,n*m);
if(!flag)
printf("NOn");
else
{
printf("YESn");
for(int i=1;i<=n;i++)
{
for(int j=1;j<=m;j++)
{
if(j==1)
printf("%d",ans[i][j]);
else
printf(" %d",ans[i][j]);
}
printf("n");
}
}
}
return 0;
}

 

最后

以上就是开朗背包为你收集整理的2014ACM/ICPC亚洲区北京站-B - Black And White的全部内容,希望文章能够帮你解决2014ACM/ICPC亚洲区北京站-B - Black And White所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(49)

评论列表共有 0 条评论

立即
投稿
返回
顶部