概述
定义一个二维数组:
int maze[5][5] = {
0, 1, 0, 0, 0,
0, 1, 0, 1, 0,
0, 0, 0, 0, 0,
0, 1, 1, 1, 0,
0, 0, 0, 1, 0,
};
它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。
Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input
0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0
Sample Output
(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<iostream>
#include<queue>
using namespace std;
const int MAX = 10;
int n=5, graph[MAX][MAX];
struct Position {
int x = 0, y = 0;
Position operator+(pair<int, int>& dir) {
return { x + dir.first,y + dir.second };
}
};
pair<int, int> dir[4] = { {1,0},{0,1},{0,-1},{-1,0} };
//顺序不能乱,因为0和4-1,1和4-2,方向相反,输出时需要回溯
void print(Position pos) {
if (pos.x || pos.y)
//回溯打印
print(pos + dir[4 + graph[pos.x][pos.y]]);
cout << "(" << pos.x << "," << pos.y << ")" << endl;
}
void bfs() {
Position start;
queue<Position> que;
que.push(start);
while (!que.empty()) {
for (int i = 0; i < 4; i++) {
Position pos = que.front() + dir[i];
if (pos.x >= 0 && pos.x < n && pos.y >= 0 && pos.y < n && !graph[pos.x][pos.y]) {
que.push(pos);
graph[pos.x][pos.y] -= (i + 1);
if (pos.x == n - 1 && pos.y == n - 1)
return;
}
}
que.pop();
}
}
int main() {
for (int i = 0; i < n; i++)
for (int j = 0; j < n; j++)
scanf("%d", &graph[i][j]);
bfs();
print({ n - 1,n - 1 });
return 0;
}
最后
以上就是拉长白开水为你收集整理的POJ3984—迷宫问题(bfs+ 打印路径)的全部内容,希望文章能够帮你解决POJ3984—迷宫问题(bfs+ 打印路径)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复