我是靠谱客的博主 无限火车,最近开发中收集的这篇文章主要介绍hdu 2844 Coins 多重背包模板题 ,二进制优化。据说是楼教主的男人八题之一Coins,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Coins
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)Total Submission(s): 8052 Accepted Submission(s): 3291
Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn't know the exact price of the watch.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony's coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
Output
For each test case output the answer on a single line.
Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
Sample Output
8 4
最近一直在做DP的题目,,都是一些模板题,,现在已成了背包九讲作者的死忠了。如果我是女的,,我一定要嫁给写出背包九讲的男人o(╯□╰)o
先说一下二进制优化的原理:
1、2、4可以组合出所有小于8的数;
1、2、4、8可以组合出所有小于16的数;
1、2、4、8、16可以组合出所有小于32的数;
1、2、4、8可以组合出所有小于16的数;
1、2、4、8、16可以组合出所有小于32的数;
我的代码:
#include <stdio.h>
#include <string.h>
#define M 100100
#define N 110
int a[N] , c[N] , dp[M] ;
void zeroOnePack(int value , int m)
{
for(int i = m ; i >= value ; --i)
{
if(dp[i]<dp[i-value]+value)
{
dp[i] = dp[i-value]+value ;
}
}
}
void completePack(int value , int m)
{
for(int i = value ; i <= m ; ++i)
{
if(dp[i]<dp[i-value]+value)
{
dp[i] = dp[i-value]+value ;
}
}
}
void multiplePack(int value , int count , int total)
{
if(value*count>total)
{
completePack(value , total) ;
}
else
{
int k = 1 ;
while(k<=count)
{
zeroOnePack(k*value , total) ;
count -= k ;
k = 2*k ;
}
zeroOnePack(count*value,total) ;
}
}
int main()
{
int n ,m ;
while(~scanf("%d%d",&n,&m) && (n||m))
{
for(int i = 0 ; i < n ; ++i)
{
scanf("%d",&a[i]);
}
for(int i = 0 ; i < n ; ++i)
{
scanf("%d",&c[i]);
}
memset(dp,0,sizeof(dp)) ;
for(int i = 0 ; i < n ; ++i)
{
multiplePack(a[i],c[i],m);
}
int ans = 0 ;
for(int i = 1 ; i <= m ; ++i)
{
if(i == dp[i])
{
++ans ;
}
}
printf("%dn",ans) ;
}
return 0 ;
}
最后
以上就是无限火车为你收集整理的hdu 2844 Coins 多重背包模板题 ,二进制优化。据说是楼教主的男人八题之一Coins的全部内容,希望文章能够帮你解决hdu 2844 Coins 多重背包模板题 ,二进制优化。据说是楼教主的男人八题之一Coins所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复