我是靠谱客的博主 奋斗水蜜桃,最近开发中收集的这篇文章主要介绍搭积木的诀窍(数学题),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

搭积木的诀窍

时间限制: 1 Sec  内存限制: 128 MB

题目描述

小Q的编程技术在一次搭积木比赛中也成了秘密武器。原来,比赛的规则是这样的:给你N个小木块(全部为一样大小的正方体),快速搭成如下图规则的形状(下图为5层的规模),要求层数为最大限度。由于小Q编了个程序,只要输入小木块个数N,就可以马上求出最多可以搭几层,还剩几个,所以小Q每次都是一次成功,从不需要翻工,速度也就领先了。你会编小Q这样的程序吗?

 

输入

只有一个整数N,表示小木块的个数,已知1≤N≤30000。

 

输出

有两行整数,第一行是最多可以堆的层数,第二行是剩余的小木块数。

 

样例输入

复制样例数据

37

样例输出

5
2

an = n*(n+1)/2,an表示第n层有多少块,sn=1/2(n*(n+1)*(2*n+1)/6 + n*(n+1)/2);

/**/
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cctype>
#include <iostream>
#include <algorithm>
#include <map>
#include <set>
#include <vector>
#include <string>
#include <stack>
#include <queue>
typedef long long LL;
using namespace std;
int n;
int main()
{
//freopen("in.txt", "r", stdin);
//freopen("out.txt", "w", stdout);
scanf("%d", &n);
int ans, lea;
for (int i = 1; i <= n; i++){
int sum = (i * (i + 1) * (2 * i + 1) + 3 * i * (i + 1)) / 12;
if(sum > n){
ans = i;
break;
}
}
ans--;
lea = n - (ans * (ans + 1) * (2 * ans + 1) + 3 * ans * (ans + 1)) / 12;
printf("%dn%dn", ans, lea);
return 0;
}
/**/

 

最后

以上就是奋斗水蜜桃为你收集整理的搭积木的诀窍(数学题)的全部内容,希望文章能够帮你解决搭积木的诀窍(数学题)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(46)

评论列表共有 0 条评论

立即
投稿
返回
顶部