概述
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。
这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过200岁的老人,而今天是2014年9月6日,所以超过200岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式:
输入在第一行给出正整数N,取值在(0, 10^5^];随后N行,每行给出1个人的姓名(由不超过5个英文字母组成的字符串)、以及按“yyyy/mm/dd”(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
我最先想到的解题思路是排序算法,符合年龄的进入vector,然后排序输出就可以了,代码如下:
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;
struct people{
int year, month, day;
string name;
};
bool cmp(people p1, people p2)
{
if (p1.year != p2.year)
return p1.year < p2.year;
else if (p1.month != p2.month)
return p1.month < p2.month;
else
return p1.day < p2.day;
}
int main()
{
int n,tmpye,tmpmon,tmpday;
string na;
people tmpperson;
vector <people> person;
cin >> n;
for (int i = 0; i < n; i++)
{
cin >> na;
scanf("%d/%d/%d", &tmpye, &tmpmon, &tmpday);
tmpperson.name = na;
tmpperson.year = tmpye;
tmpperson.month = tmpmon;
tmpperson.day = tmpday;
if (tmpye < 1814 || (tmpye == 1814 && tmpmon < 9) || (tmpye == 1814 && tmpmon == 9 && tmpday < 6) || tmpye > 2014 || (tmpye == 2014 && tmpmon > 9) || (tmpye == 2014 && tmpmon == 9 && tmpday > 6))
continue;
else
person.push_back(tmpperson);
}
sort(person.begin(), person.end(), cmp);
cout<<person.size();
if(person.size()!=0)
cout<< " "<<person.front().name <<" "<<person.back().name;
return 0;
}
但是这样的话比较麻烦,我们只需要找出最大最小的年龄就可以了,所以删减后的代码如下:
#include <iostream>
#include <string>
using namespace std;
int main()
{
int maxyear = 9999, maxmonth = 9999, maxday = 9999;
int minyear = 0, minmonth = 0, minday = 0;
int n,tmpye,tmpmon,tmpday,count=0;
string na,minname,maxname;
cin >> n;
for (int i = 0; i < n; i++){
cin >> na;
scanf("%d/%d/%d", &tmpye, &tmpmon, &tmpday);
if (tmpye < 1814 || (tmpye == 1814 && tmpmon < 9) || (tmpye == 1814 && tmpmon == 9 && tmpday < 6) || tmpye > 2014 || (tmpye == 2014 && tmpmon > 9) || (tmpye == 2014 && tmpmon == 9 && tmpday > 6))
continue;
else{
count++;
if (tmpye > minyear || (tmpye == minyear&&tmpmon > minmonth) || (tmpye == minyear&&tmpmon == minmonth&&tmpday > minday))
{
minyear = tmpye; minmonth = tmpmon; minday = tmpday; minname = na;
}
if (tmpye < maxyear || (tmpye == maxyear&&tmpmon < maxmonth) || (tmpye == maxyear&&tmpmon == maxmonth&&tmpday < maxday))
{
maxyear = tmpye; maxmonth = tmpmon; maxday = tmpday; maxname = na;
}
}
}
cout << count;
if (count!=0)
cout<<" " << maxname <<" "<< minname;
return 0;
}
最后
以上就是淡淡钢铁侠为你收集整理的【PAT乙级】1028 人口普查(20)的全部内容,希望文章能够帮你解决【PAT乙级】1028 人口普查(20)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复