概述
Excel can sort records according to any column(列). Now you are supposed to imitate(模仿) this function.
Input Specification:
Each input file contains one test case. For each case, the first line contains two integers N (≤105) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct(不同的) ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive(包含在内的)).
Output Specification:
For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.
Sample Input 1:
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1:
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2:
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2:
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3:
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 9
Sample Output 3:
000002 James 9
000001 Zoe 60
000007 James 85
000010 Amy 90
思路:本题要求按照不同的指令实现不同的排序,根据排序规则改写sort的排序规则即可
AC代码
#include <iostream>
#include <string>
#include <algorithm>
#include <vector>
using namespace std;
struct student
{
string id;
string name;
int score;
};
bool cmp1(student x,student y)
{
return x.id<y.id;
}
bool cmp2(student x,student y)
{
if(x.name!=y.name)
return x.name<y.name;
else
return x.id<y.id;
}
bool cmp3(student x,student y)
{
if(x.score!=y.score)
return x.score<y.score;
else
return x.id<y.id;
}
int main()
{
int n,c;
vector<student> a;
string id,name;
int score;
cin>>n>>c;
for(int i=0;i<n;i++)
{
cin>>id>>name>>score;
a.push_back({id,name,score});
}
if(c==1)
sort(a.begin(),a.end(),cmp1);
else if(c==2)
sort(a.begin(),a.end(),cmp2);
else if(c==3)
sort(a.begin(),a.end(),cmp3);
for(int i=0;i<n;i++)
cout<<a[i].id<<" "<<a[i].name<<" "<<a[i].score<<endl;
return 0;
}
最后
以上就是唠叨咖啡为你收集整理的1028 List Sorting (25 分)-PAT甲级的全部内容,希望文章能够帮你解决1028 List Sorting (25 分)-PAT甲级所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复