我是靠谱客的博主 舒服天空,最近开发中收集的这篇文章主要介绍PAT - 甲级 - 1028. List Sorting (25)(排序),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90
000010 Amy 90

给定条件:
1.N条记录,排序准则C

要求:
1.按照给定准则将N条记录排序后输出

求解:
1.按照准则排序即可

注意:
1.为了避免超时,应尽量避免使用string,用char数组来代替


#include <iostream>
#include <algorithm>
#include <cstdio>
#include <vector>
#include <cstring>
using namespace std;
struct Student {
char record[3][10];
} st;
int n, c;
bool cmp(Student st1, Student st2) {
return strcmp(st1.record[c], st2.record[c])!=0 ?
strcmp(st1.record[c], st2.record[c])<=0 : strcmp(st1.record[0], st2.record[0])<=0;
}
vector<Student> v;
int main() {
scanf("%d%d", &n, &c);
for(int i = 0; i < n; i++) {
scanf("%s%s%s", st.record[0], st.record[1], st.record[2]);
v.push_back(st);
}
c -= 1;
sort(v.begin(), v.end(), cmp);
for(int i = 0; i < v.size(); i++) {
printf("%s %s %sn", v[i].record[0], v[i].record[1], v[i].record[2] );
}
return 0;
}



最后

以上就是舒服天空为你收集整理的PAT - 甲级 - 1028. List Sorting (25)(排序)的全部内容,希望文章能够帮你解决PAT - 甲级 - 1028. List Sorting (25)(排序)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(55)

评论列表共有 0 条评论

立即
投稿
返回
顶部