概述
某城镇进行人口普查,得到了全体居民的生日。现请你写个程序,找出镇上最年长和最年轻的人。
这里确保每个输入的日期都是合法的,但不一定是合理的——假设已知镇上没有超过 200 岁的老人,而今天是 2014 年 9 月 6 日,所以超过 200 岁的生日和未出生的生日都是不合理的,应该被过滤掉。
输入格式:
输入在第一行给出正整数 N,取值在(0,105];随后 N 行,每行给出 1 个人的姓名(由不超过 5 个英文字母组成的字符串)、以及按 yyyy/mm/dd
(即年/月/日)格式给出的生日。题目保证最年长和最年轻的人没有并列。
输出格式:
在一行中顺序输出有效生日的个数、最年长人和最年轻人的姓名,其间以空格分隔。
输入样例:
5
John 2001/05/12
Tom 1814/09/06
Ann 2121/01/30
James 1814/09/05
Steve 1967/11/20
输出样例:
3 Tom John
解题思路:
#include <stdio.h>
#include <stdlib.h>
typedef struct _People {
char name[8];
int year, month, day;
} People;
int compare(const void *a, const void *b)
{
const People *pa = a;
const People *pb = b;
if ( pa->year!=pb->year ) {
return pa->year - pb->year;
} else if ( pa->month!=pb->month ) {
return pa->month - pb->month;
} else {
return pa->day - pb->day;
}
}
int main(int argc, const char *argv[])
{
int N, i, j;
if ( scanf("%d", &N)==EOF ) printf("errorn");
People people[N];
People today = {"",2014,9,6};
People temp;
for ( i=0, j=0; i<N; i++ ) {
if ( scanf("%s%d/%d/%d", temp.name, &temp.year, &temp.month, &temp.day)==EOF ) printf("errorn");
if ( temp.year<today.year-200 ) {
continue;
} else if ( temp.year==today.year-200 && temp.month<today.month ) {
continue;
} else if ( temp.year==today.year-200 && temp.month==today.month && temp.day<today.day ) {
continue;
} else if ( temp.year>today.year ) {
continue;
} else if ( temp.year==today.year && temp.month>today.month ) {
continue;
} else if ( temp.year==today.year && temp.month==today.month && temp.day>today.day ) {
continue;
}
people[j++] = temp;
}
qsort(people, j, sizeof(people[0]), compare);
j==0 ? printf("0n") : printf("%d %s %sn", j, people[0].name, people[j-1].name) ;
return 0;
}
最后
以上就是鲤鱼蜻蜓为你收集整理的pat basic 1028 人口普查的全部内容,希望文章能够帮你解决pat basic 1028 人口普查所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复