我是靠谱客的博主 故意鼠标,最近开发中收集的这篇文章主要介绍PAT(甲级)1028 1028. List Sorting (25),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

1028. List Sorting (25)

时间限制
200 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

Excel can sort records according to any column. Now you are supposed to imitate this function.

Input

Each input file contains one test case. For each case, the first line contains two integers N (<=100000) and C, where N is the number of records and C is the column that you are supposed to sort the records with. Then N lines follow, each contains a record of a student. A student's record consists of his or her distinct ID (a 6-digit number), name (a string with no more than 8 characters without space), and grade (an integer between 0 and 100, inclusive).

Output

For each test case, output the sorting result in N lines. That is, if C = 1 then the records must be sorted in increasing order according to ID's; if C = 2 then the records must be sorted in non-decreasing order according to names; and if C = 3 then the records must be sorted in non-decreasing order according to grades. If there are several students who have the same name or grade, they must be sorted according to their ID's in increasing order.

Sample Input 1
3 1
000007 James 85
000010 Amy 90
000001 Zoe 60
Sample Output 1
000001 Zoe 60
000007 James 85
000010 Amy 90
Sample Input 2
4 2
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 98
Sample Output 2
000010 Amy 90
000002 James 98
000007 James 85
000001 Zoe 60
Sample Input 3
4 3
000007 James 85
000010 Amy 90
000001 Zoe 60
000002 James 90
Sample Output 3
000001 Zoe 60
000007 James 85
000002 James 90

000010 Amy 90

#include <stdio.h>
#include <string.h>
#define MAX 100005

using namespace std;

struct Student{
	char ID[16];
	char name[16];
	int grade;
};

Student student[MAX];

bool mycmp(Student &s1,Student &s2,long i){
	switch (i){
		case 1:{
			if(strcmp(s1.ID,s2.ID) <0)
			    return true;
			else
			    return false;
		}
		case 2:{
    		if(strcmp(s1.name,s2.name) < 0)
			    return true;
			else if(strcmp(s1.name,s2.name)==0){
				if(strcmp(s1.ID ,s2.ID) <0)
				    return true;
				else
				    return false;
			}else
			    return false;
		}
		case 3:{
			if(s1.grade <s2.grade)
			    return true;
			else if(s1.grade == s2.grade){
				if(strcmp(s1.ID ,s2.ID) <0)
				    return true;
				else
				    return false;
			}else
			    return false;
		}
	
	}
	
}

void swap(Student &s1,Student &s2){
	Student tmp = s1;
	s1 =s2;
	s2 =tmp;
}

long partion(Student p[],long low,long high,long c){
	long key=(low+high)/2;
	swap(p[key],p[high]);
	long i =low;
	long j = high-1;
	while(1){
		while(mycmp(p[i],p[high],c) &&i<high)
		    i++;
		while(mycmp(p[high],p[j],c)&&j>0)
		    j--;
		if(i<j)
		    swap(p[i],p[j]);
		else
		    break;
	}
	if(i !=high)
	    swap(p[i],p[high]);
	return i;
	
}

void mysort(Student p[],long low,long high,long c)
{
	long key;
	if(low < high){
		key = partion(p,low,high,c);
		mysort(p,low,key-1,c);
		mysort(p,key+1,high,c);
	}
}

void display(Student p[],long n)
{
	long i=0;
	while(i<n){
		printf("%s %s %dn",p[i].ID,p[i].name,p[i].grade);
		i++;
	}
}

int main()
{
	long N,C,i;
	scanf("%ld %ld",&N,&C);
//	cin >>N >>C;
	for(i=0;i<N;i++){
		scanf("%s %s %d",student[i].ID,student[i].name,&student[i].grade);
//		cin >>student[i].ID >>student[i].name >>student[i].grade;
	}
	mysort(student,0,N-1,C);
	display(student,N);
	return 0;
}


最后

以上就是故意鼠标为你收集整理的PAT(甲级)1028 1028. List Sorting (25)的全部内容,希望文章能够帮你解决PAT(甲级)1028 1028. List Sorting (25)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(54)

评论列表共有 0 条评论

立即
投稿
返回
顶部