我是靠谱客的博主 隐形裙子,最近开发中收集的这篇文章主要介绍CodeForces 118 A.String Task(水~),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

给出一个只有大小写字母的字符串,做如下处理:

1.删除所有元音字母(A,O,Y,E,U,I)

2.在每个辅音字母前加一个.

3.把所有大写辅音字母变成小写

Input

一个长度不超过100的字符串

Output

输出处理后的字符串

Sample Input

tour

Sample Output

.t.r

Solution

水题

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
char s[maxn];
int check(char c)
{
    if(c>='a'&&c<='z')c=c-'a'+'A';
    if(c=='A'||c=='O'||c=='Y'||c=='E'||c=='U'||c=='I')return 1;
    return 0;
}
char deal(char c)
{
    if(c>='A'&&c<='Z')return c-'A'+'a';
    return c;
}
int main()
{
    scanf("%s",s);
    int n=strlen(s);
    for(int i=0;i<n;i++)
    {
        if(check(s[i]))continue;
        s[i]=deal(s[i]);
        printf(".%c",s[i]);
    }
    printf("n");
    return 0;
}

最后

以上就是隐形裙子为你收集整理的CodeForces 118 A.String Task(水~)的全部内容,希望文章能够帮你解决CodeForces 118 A.String Task(水~)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(34)

评论列表共有 0 条评论

立即
投稿
返回
顶部