概述
Description
给出一整数
n
,求大于
Input
一个正整数 n(1000≤n≤9000)
Output
输出大于 n 的最小的满足条件的数字
Sample Input
1987
Sample Output
2013
Solution
水题,从
Code
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int check(int n)
{
int a[5],res=0;
while(n)
{
a[res++]=n%10,n/=10;
}
for(int i=0;i<res;i++)
for(int j=i+1;j<res;j++)
if(a[i]==a[j])return 0;
return 1;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=n+1;;i++)
if(check(i))
{
printf("%dn",i);
break;
}
}
return 0;
}
最后
以上就是沉静石头为你收集整理的CodeForces 271 A.Beautiful Year(水~)的全部内容,希望文章能够帮你解决CodeForces 271 A.Beautiful Year(水~)所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复