Description
给出一整数
n
,求大于
Input
一个正整数 n(1000≤n≤9000)
Output
输出大于 n 的最小的满足条件的数字
Sample Input
1987
Sample Output
2013
Solution
水题,从
Code
复制代码
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int check(int n)
{
int a[5],res=0;
while(n)
{
a[res++]=n%10,n/=10;
}
for(int i=0;i<res;i++)
for(int j=i+1;j<res;j++)
if(a[i]==a[j])return 0;
return 1;
}
int main()
{
int n;
while(~scanf("%d",&n))
{
for(int i=n+1;;i++)
if(check(i))
{
printf("%dn",i);
break;
}
}
return 0;
}
最后
以上就是沉静石头最近收集整理的关于CodeForces 271 A.Beautiful Year(水~)的全部内容,更多相关CodeForces内容请搜索靠谱客的其他文章。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复