我是靠谱客的博主 阔达大白,最近开发中收集的这篇文章主要介绍Tram(最短路),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Tram(最短路)

Tram network in Zagreb consists of a number of intersections and rails connecting some of them. In every intersection there is a switch pointing to the one of the rails going out of the intersection. When the tram enters the intersection it can leave only in the direction the switch is pointing. If the driver wants to go some other way, he/she has to manually change the switch.

When a driver has do drive from intersection A to the intersection B he/she tries to choose the route that will minimize the number of times he/she will have to change the switches manually.

Write a program that will calculate the minimal number of switch changes necessary to travel from intersection A to intersection B.

Input
The first line of the input contains integers N, A and B, separated by a single blank character, 2 <= N <= 100, 1 <= A, B <= N, N is the number of intersections in the network, and intersections are numbered from 1 to N.

Each of the following N lines contain a sequence of integers separated by a single blank character. First number in the i-th line, Ki (0 <= Ki <= N-1), represents the number of rails going out of the i-th intersection. Next Ki numbers represents the intersections directly connected to the i-th intersection.Switch in the i-th intersection is initially pointing in the direction of the first intersection listed.

Output
The first and only line of the output should contain the target minimal number. If there is no route from A to B the line should contain the integer “-1”.

Sample Input
3 2 1
2 2 3
2 3 1
2 1 2

Sample Output
0

题意: 交叉路口处默认指向第一条路,若想走其他路,需手动改变机关,问最少改变几次机关能从a到b,若不能从a到b输出-1

思路: 好久不写,脑子确实不好使了 ,能看出来要使用最短路来做,那我们就得初始两点之间的距离了,题求最小改变机关次数,那我们就记需要改变机关的两点间距离为1,不需要改变机关为0,这样算出的最短路,实际上是最小改变机关的次数

AC代码:

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
#include<algorithm>
using namespace std;
int e[110][110];
int main()
{
int n,a,b,i,j,k;
scanf("%d%d%d",&n,&a,&b);
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
{
if(i==j)
e[i][j]=0;
else
e[i][j]=inf;
}
int c,d,x;
for(i=1; i<=n; i++)
{
d=0;//不需要手动换挡的为0,需要的为1
scanf("%d",&c);
for(j=0; j<c; j++)
{
scanf("%d",&x);
e[i][x]=d;
d=1;
}
}
for(k=1; k<=n; k++)
for(i=1; i<=n; i++)
for(j=1; j<=n; j++)
if(e[i][j]>e[i][k]+e[k][j])
e[i][j]=e[i][k]+e[k][j];
if(e[a][b]==inf)
printf("-1n");
else
printf("%dn",e[a][b]);
return 0;
}

最后

以上就是阔达大白为你收集整理的Tram(最短路)的全部内容,希望文章能够帮你解决Tram(最短路)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(48)

评论列表共有 0 条评论

立即
投稿
返回
顶部