我是靠谱客的博主 香蕉人生,最近开发中收集的这篇文章主要介绍CodeForces 344 A.Magnets(水~),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

n 块磁铁排成一排,磁铁有两种状态,01和10分别表示正极的不同方向,问最后这些磁铁会变成几段

Input

第一行一整数n表示磁铁的个数,之后 n 行每行01或10表示该块磁铁的状态(1n100000)

Output

输出这些磁铁最后会分成多少段

Sample Input

6
10
10
10
01
10
10

Sample Output

3

Solution

水题,只要相邻两个磁铁的状态不用则段数加一

Code

#include<cstdio>
#include<iostream>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<vector>
#include<queue>
#include<map>
#include<set>
#include<ctime>
using namespace std;
typedef long long ll;
typedef pair<int,int>P;
const int INF=0x3f3f3f3f,maxn=100001;
int n,a[maxn];
int main()
{
while(~scanf("%d",&n))
{
int num=1;
for(int i=1;i<=n;i++)scanf("%d",&a[i]);
for(int i=2;i<=n;i++)if(a[i]!=a[i-1])num++;
printf("%dn",num);
}
return 0;
}

最后

以上就是香蕉人生为你收集整理的CodeForces 344 A.Magnets(水~)的全部内容,希望文章能够帮你解决CodeForces 344 A.Magnets(水~)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(39)

评论列表共有 0 条评论

立即
投稿
返回
顶部