我是靠谱客的博主 美丽学姐,最近开发中收集的这篇文章主要介绍C++——USACO Section 1.5 题解Number TrianglesPrime PalindromesSuperprime Rib,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Number Triangles
Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.
7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.
PROGRAM NAME: numtri
INPUT FORMAT
The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.SAMPLE INPUT (file numtri.in)
5 7 3 8 8 1 0 2 7 4 4 4 5 2 6 5
OUTPUT FORMAT
A single line containing the largest sum using the traversal specified.SAMPLE OUTPUT (file numtri.out)
30
#include<cstdio>
int f[1001][1001],ans;
inline int readint()
{
int i=0;
char ch;
for(ch=getchar();ch<'0'||ch>'9';ch=getchar());
for(;ch>='0' && ch<='9';ch=getchar())
i=(i<<3)+(i<<1)+ch-'0';
return i;
}
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int n;
n=readint();
for(int i=1;i<=n;++i)
for(int j=1;j<=i;++j)
f[i][j]=readint();
for(int i=1;i<=n;++i)
for(int j=1;j<=i;++j)
f[i][j]+=max(f[i-1][j-1],f[i-1][j]);
for(int i=1;i<=n;++i) ans=max(ans,f[n][i]);
int num=0;
char c[12];
do
{
c[++num]=(ans%10)+48;
ans/=10;
}while(ans);
while(num) putchar(c[num--]);
return 0;
}
Prime Palindromes
The number 151 is a prime palindrome because it is both a prime number and a palindrome (it is the same number when read forward as backward). Write a program that finds all prime palindromes in the range of two supplied numbers a and b (5 <= a < b <= 100,000,000); both a and b are considered to be within the range .
PROGRAM NAME: pprime
INPUT FORMAT
Line 1: | Two integers, a and b |
SAMPLE INPUT (file pprime.in)
5 500
OUTPUT FORMAT
The list of palindromic primes in numerical order, one per line.SAMPLE OUTPUT (file pprime.out)
5 7 11 101 131 151 181 191 313 353 373 383
#include <stdio.h>
#include <string.h>
#include <assert.h>
#include <stdlib.h>
FILE *fout;
long a, b;
int
isprime(long n)
{
long i;
if(n == 2)
return 1;
if(n%2 == 0)
return 0;
for(i=3; i*i <= n; i+=2)
if(n%i == 0)
return 0;
return 1;
}
void
gen(int i, int isodd)
{
char buf[30];
char *p, *q;
long n;
sprintf(buf, "%d", i);
p = buf+strlen(buf);
q = p - isodd;
while(q > buf)
*p++ = *--q;
*p = '