我是靠谱客的博主 美丽学姐,最近开发中收集的这篇文章主要介绍C++——USACO Section 1.5 题解Number TrianglesPrime PalindromesSuperprime Rib,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Number Triangles

Consider the number triangle shown below. Write a program that calculates the highest sum of numbers that can be passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

7
3
8
8
1
0
2
7
4
4
4
5
2
6
5

In the sample above, the route from 7 to 3 to 8 to 7 to 5 produces the highest sum: 30.

PROGRAM NAME: numtri

INPUT FORMAT

The first line contains R (1 <= R <= 1000), the number of rows. Each subsequent line contains the integers for that particular row of the triangle. All the supplied integers are non-negative and no larger than 100.

SAMPLE INPUT (file numtri.in)

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

OUTPUT FORMAT

A single line containing the largest sum using the traversal specified.

SAMPLE OUTPUT (file numtri.out)

30
#include<cstdio>
int f[1001][1001],ans;
inline int readint()
{
int i=0;
char ch;
for(ch=getchar();ch<'0'||ch>'9';ch=getchar());
for(;ch>='0' && ch<='9';ch=getchar())
i=(i<<3)+(i<<1)+ch-'0';
return i;
}
int max(int a,int b)
{
return a>b?a:b;
}
int main()
{
int n;
n=readint();
for(int i=1;i<=n;++i)
for(int j=1;j<=i;++j)
f[i][j]=readint();
for(int i=1;i<=n;++i)
for(int j=1;j<=i;++j)
f[i][j]+=max(f[i-1][j-1],f[i-1][j]);
for(int i=1;i<=n;++i) ans=max(ans,f[n][i]);
int num=0;
char c[12];
do
{
c[++num]=(ans%10)+48;
ans/=10;
}while(ans);
while(num) putchar(c[num--]);
return 0;
}

Prime Palindromes

The number 151 is a prime palindrome because it is both a prime number and a palindrome (it is the same number when read forward as backward). Write a program that finds all prime palindromes in the range of two supplied numbers a and b (5 <= a < b <= 100,000,000); both a and b are considered to be within the range .

PROGRAM NAME: pprime

INPUT FORMAT

Line 1:Two integers, a and b

SAMPLE INPUT (file pprime.in)

5 500

OUTPUT FORMAT

The list of palindromic primes in numerical order, one per line.

SAMPLE OUTPUT (file pprime.out)

5
7
11
101
131
151
181
191
313
353
373
383
#include <stdio.h>
#include <string.h>
#include <assert.h>
#include <stdlib.h>
FILE *fout;
long a, b;
int
isprime(long n)
{
long i;
if(n == 2)
return 1;
if(n%2 == 0)
return 0;
for(i=3; i*i <= n; i+=2)
if(n%i == 0)
return 0;
return 1;
}
void
gen(int i, int isodd)
{
char buf[30];
char *p, *q;
long n;
sprintf(buf, "%d", i);
p = buf+strlen(buf);
q = p - isodd;
while(q > buf)
*p++ = *--q;
*p = '';
n = atol(buf);
if(a <= n && n <= b && isprime(n))
fprintf(fout, "%ldn", n);
}
void
genoddeven(int lo, int hi)
{
int i;
for(i=lo; i<=hi; i++)
gen(i, 1);
for(i=lo; i<=hi; i++)
gen(i, 0);
}
void
generate(void)
{
genoddeven(1, 9);
genoddeven(10, 99);
genoddeven(100, 999);
genoddeven(1000, 9999);
}
void
main(void)
{
FILE *fin;
fin = fopen("pprime.in", "r");
fout = fopen("pprime.out", "w");
assert(fin != NULL && fout != NULL);
fscanf(fin, "%ld %ld", &a, &b);
generate();
exit (0);
}

Superprime Rib

Butchering Farmer John's cows always yields the best prime rib. You can tell prime ribs by looking at the digits lovingly stamped across them, one by one, by FJ and the USDA. Farmer John ensures that a purchaser of his prime ribs gets really prime ribs because when sliced from the right, the numbers on the ribs continue to stay prime right down to the last rib, e.g.:

7
3
3
1

The set of ribs denoted by 7331 is prime; the three ribs 733 are prime; the two ribs 73 are prime, and, of course, the last rib, 7, is prime. The number 7331 is called a superprime of length 4.

Write a program that accepts a number N 1 <=N<=8 of ribs and prints all the superprimes of that length.

The number 1 (by itself) is not a prime number.

PROGRAM NAME: sprime

INPUT FORMAT

A single line with the number N.

SAMPLE INPUT (file sprime.in)

4

OUTPUT FORMAT

The superprime ribs of length N, printed in ascending order one per line.

SAMPLE OUTPUT (file sprime.out)

2333
2339
2393
2399
2939
3119
3137
3733
3739
3793
3797
5939
7193
7331
7333
7393
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <assert.h>
FILE *fout;
int
isprime(int n)
{
int i;
if(n == 2)
return 1;
if(n%2 == 0)
return 0;
for(i=3; i*i <= n; i+=2)
if(n%i == 0)
return 0;
return 1;
}
/* print all sprimes possible by adding ndigit digits to the number n */
void
sprime(int n, int ndigit)
{
if(ndigit == 0) {
fprintf(fout, "%dn", n);
return;
}
n *= 10;
if(isprime(n+1))
sprime(n+1, ndigit-1);
if(isprime(n+3))
sprime(n+3, ndigit-1);
if(isprime(n+7))
sprime(n+7, ndigit-1);
if(isprime(n+9))
sprime(n+9, ndigit-1);
}
void main(void)
{
int n;
FILE *fin;
fin = fopen("sprime.in", "r");
assert(fin != NULL);
fout = fopen("sprime.out", "w");
assert(fout != NULL);
fscanf(fin, "%d", &n);
sprime(2, n-1);
sprime(3, n-1);
sprime(5, n-1);
sprime(7, n-1);
exit (0);
}




最后

以上就是美丽学姐为你收集整理的C++——USACO Section 1.5 题解Number TrianglesPrime PalindromesSuperprime Rib的全部内容,希望文章能够帮你解决C++——USACO Section 1.5 题解Number TrianglesPrime PalindromesSuperprime Rib所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(70)

评论列表共有 0 条评论

立即
投稿
返回
顶部