我是靠谱客的博主 大胆爆米花,最近开发中收集的这篇文章主要介绍Problem P:Prime Gap(素数打表),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

POJ3518http://poj.org/problem?id=3518

Description

The sequence of n − 1 consecutive composite numbers (positive integers that are not prime and not equal to 1) lying between two successive prime numbers p and p + n is called a prime gap of length n. For example, ‹24, 25, 26, 27, 28› between 23 and 29 is a prime gap of length 6.

Your mission is to write a program to calculate, for a given positive integer k, the length of the prime gap that contains k. For convenience, the length is considered 0 in case no prime gap contains k.

Input

The input is a sequence of lines each of which contains a single positive integer. Each positive integer is greater than 1 and less than or equal to the 100000th prime number, which is 1299709. The end of the input is indicated by a line containing a single zero.

Output

The output should be composed of lines each of which contains a single non-negative integer. It is the length of the prime gap that contains the corresponding positive integer in the input if it is a composite number, or 0 otherwise. No other characters should occur in the output.

Sample Input

10
11
27
2
492170
0

Sample Output

4
0
6
0
114

Source Code

#include<iostream>
#include<cstring>
#define N 5000005
#define ll long long
using namespace std;
ll n;
ll primes[N];
ll cnt;
bool prime[N];
void make_prime()
{
    memset(prime,true,sizeof(prime));
    prime[0]=false;
    prime[1]=false;
    for(ll i=2;i<=N;i++)
    {
        if(prime[i])
        {
            primes[cnt++]=i;
            for(ll k=i*i;k<=N;k+=i)
                prime[k]=false;
        }
    }
}
int main()
{
    make_prime();//打表
    while(cin>>n&&n)
    {
        if(prime[n])//本身是素数,长度为0
            cout<<0<<endl;
        else
        {
            for(ll i=0;i<cnt;i++)
            {
                if(primes[i]<n&&primes[i+1]>n)
                    cout<<primes[i+1]-primes[i]<<endl;//找到n两边的素数,相减得长度
            }
        }
    }
    return 0;
}

 

最后

以上就是大胆爆米花为你收集整理的Problem P:Prime Gap(素数打表)的全部内容,希望文章能够帮你解决Problem P:Prime Gap(素数打表)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(45)

评论列表共有 0 条评论

立即
投稿
返回
顶部