概述
Problem Description
输入一个正整数n(1<=n<=10),再输入n*n的矩阵,要求求该矩阵的下三角元素之和。
Input
输入包括n+1行。 第一行为整数n;
接下来的n行为矩阵数据。
Output
矩阵的下三角元素之和。
Sample Input
5
1 2 3 4 5
2 3 4 5 6
3 4 5 6 7
4 5 6 7 8
5 6 7 8 9
Sample Output
75
删除线格式
import java.util.Scanner;
public class Main{
public static void main(String []args){
Scanner reader = new Scanner(System.in);
int n = reader.nextInt();
int a[][] = new int [n][n];
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
a[i][j] = reader.nextInt();
}
}
int sum = 0;
for(int i = 0; i < n; i++){
for(int j = 0; j <= i; j++)
{
sum = sum + a[i][j];
}
}
System.out.println(sum);
}
}
最后
以上就是愤怒芹菜为你收集整理的java实验——矩阵下三角元素之和的全部内容,希望文章能够帮你解决java实验——矩阵下三角元素之和所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复