我是靠谱客的博主 耍酷御姐,最近开发中收集的这篇文章主要介绍Rescue (ZOJ - 1649 ),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

Input

First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

Output

For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

Sample Input

7 8 
#.#####. 
#.a#..r. 
#..#x... 
..#..#.# 
#...##.. 
.#...... 
........

Sample Output

13

题解:天使(a)被困于迷宫,它的朋友(r)去救她,在迷宫中会有守卫(x)。r每走一步耗费一个单位的时间,如果路途遇上x,杀死x则需要一个单位的时间,求r找到a的最短时间。此题是一个迷宫问题,求解最短路径。使用广度优先搜索可解。

代码如下:

#include <iostream>
#include <cstdio>
#include <stdlib.h>
#include <cmath>
#include <cstring>
#include <algorithm>
#include <string.h>
#include <vector>
#include <queue>
#include <stack>
#include <set>
#include <map>
#include <ctime>
#define maxn 1007
#define N 100005
#define INF 0x3f3f3f3f
#define PI acos(-1)
#define lowbit(x) (x&(-x))
#define eps 0.000000001
#define read(x) scanf("%d",&x)
#define put(x) printf("%dn",x)
#define Debug(x) cout<<x<<" "<<endl
using namespace std;
typedef long long ll;
const int direction[4][2]={{-1,0},{1,0},{0,-1},{0,1} };//四个方向
int row,col;//行、列
int startR,startC;//起始点行列
char maze[200][201];//迷宫
bool visit[200][201];//标记
int bfs()
{
queue<int>open;
open.push(startR);
open.push(startC);
open.push(0);
visit[startR][startC]=true;
while(!open.empty())
{
int r=open.front();
open.pop();
int c=open.front();
open.pop();
int t=open.front();
open.pop();
if(maze[r][c]=='a')
{
return t;
}
else if(maze[r][c]=='x')
{
maze[r][c]='.';
open.push(r);
open.push(c);
open.push(t+1);
continue;
}
for(int d=0; d<4; ++d)
{
int dr=r+direction[d][0];
int dc=c+direction[d][1];
if(dr>=0 && dr<row && dc>=0 && dc<col&&maze[dr][dc]!='#' && !visit[dr][dc])
{
visit[dr][dc]=true;
open.push(dr);
open.push(dc);
open.push(t+1);
}
}
}
return -1;
}
int main()
{
while(scanf("%d%d",&row,&col)!=EOF)
{
for(int i=0; i<row; ++i)
{
scanf("%s",maze[i]);
for(int k=0; k<col; ++k)
{
if(maze[i][k]=='r')
{
startR=i;
startC=k;
}
visit[i][k]=false;
}
}
int t=bfs();
if(t==-1)
printf("Poor ANGEL has to stay in the prison all his life.n");
else
printf("%dn",t);
}
return 0;
}

 

最后

以上就是耍酷御姐为你收集整理的Rescue (ZOJ - 1649 )的全部内容,希望文章能够帮你解决Rescue (ZOJ - 1649 )所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(71)

评论列表共有 0 条评论

立即
投稿
返回
顶部