我是靠谱客的博主 坦率棒棒糖,最近开发中收集的这篇文章主要介绍HDU-1242 Rescue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目来源:http://acm.hdu.edu.cn/showproblem.php?pid=1242
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
 

Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend. 

Process to the end of the file.
 

Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life." 
 

Sample Input
  
  
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
 

Sample Output
  
  
13
 

Author
CHEN, Xue

简单 的bfs,套用模板就能ac
#include<iostream>
#include<cstdio>

using namespace std;

#define MAXN 220

const int d[][2]={{1,0},{0,-1},{0,1},{-1,0}}; 
int starti,startj,endi,endj;
struct Node
{
	int x,y,step;
	Node(){}
	Node(int a,int b,int c):x(a),y(b),step(c){}
}que[MAXN*MAXN];

int n,m;

bool vis[MAXN][MAXN];

char map[MAXN][MAXN];

int bfs() 
{
	int h,t;
	for(int i=0;i<n;i++)
		for(int j=0;j<m;j++) vis[i][j]=false;
	vis[starti][startj]=true;
	que[h=t=0]=Node(starti,startj,0);
	while(h<=t)
	{
		int x=que[h].x,y=que[h].y,step=que[h++].step;
		if(x==endi && y==endj) return step;
		for(int i=0;i<4;i++)
		{
			int tx=x+d[i][0],ty=y+d[i][1];
			if(tx>=n || tx<0 || ty>=m || ty<0) continue;
			if(map[tx][ty]=='#' || vis[tx][ty]) continue;
			vis[tx][ty]=true;
			if(map[tx][ty]=='x') step++;
			que[++t]=Node(tx,ty,step+1);
		}
	}
	return -1;
}

int main()
{
	while(cin>>n>>m)
	{
		int i,j;
		for(i=0;i<n;i++)
			for(j=0;j<m;j++){
				cin>>map[i][j];		
				if(map[i][j]=='r') {starti=i;startj=j;}
				else if(map[i][j]=='a') {endi=i;endj=j;}
			}
			if(bfs()!=-1)		cout<<bfs()<<endl;
			else cout<<"Poor ANGEL has to stay in the prison all his life."<<endl;
	}
	return 0;
}

 

最后

以上就是坦率棒棒糖为你收集整理的HDU-1242 Rescue的全部内容,希望文章能够帮你解决HDU-1242 Rescue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(42)

评论列表共有 0 条评论

立即
投稿
返回
顶部