我是靠谱客的博主 想人陪萝莉,最近开发中收集的这篇文章主要介绍PKU3278 Catch That Cow 基础广搜,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述







Catch That Cow
Time Limit: 2000MS        Memory Limit: 65536K
Total Submissions: 9268        Accepted: 2791

Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input
Line 1: Two space-separated integers: N and K

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input

5 17

Sample Output

4

Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

Source
USACO 2007 Open Silver*/


#include <iostream>
#include <queue>
using namespace std;
int flag[100001] = {0};
void BFS(int N,int K)
{
    int i;
    queue<int> a;
    a.push(N);
    while(!a.empty())
    {
        i = a.front();
        if(i == K)
        {
            cout<<flag[i]<<endl;
            return;
        }
        if(i + 1 <= 100000 && flag[i + 1] == 0)
        {
            flag[i + 1] = flag[i] + 1;
            a.push(i + 1);
        }
        if(i - 1 >= 0 && flag[i - 1] == 0)
        {
            flag[i - 1] = flag[i] + 1;
            a.push(i - 1);
        }
        if(i * 2 <= 100000 && flag[i * 2] == 0)
        {
            flag[i * 2] = flag[i] + 1;
            a.push(i * 2);
        }
        a.pop();
    }
    return;
}
int main(void)
{
    int N,K;
    cin>>N>>K;
   
    BFS(N,K);
    return 0;
}
第一次写广搜题。。这题很简单。。。没啥可说

最后

以上就是想人陪萝莉为你收集整理的PKU3278 Catch That Cow 基础广搜的全部内容,希望文章能够帮你解决PKU3278 Catch That Cow 基础广搜所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(58)

评论列表共有 0 条评论

立即
投稿
返回
顶部