我是靠谱客的博主 负责小海豚,最近开发中收集的这篇文章主要介绍HDU2717:Catch That Cow(BFS),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description
Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute
* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?
 

Input
Line 1: Two space-separated integers: N and K
 

Output
Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.
 

Sample Input
5 17
 

Sample Output
4
Hint
The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.


 

对所有状况进行一次搜索,最先找到的肯定就是时间最少的。

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;
const int N = 1000000;
int map[N+10];
int n,k;
struct node
{
int x,step;
};
int check(int x)
{
if(x<0 || x>=N || map[x])
return 0;
return 1;
}
int bfs(int x)
{
int i;
queue<node> Q;
node a,next;
a.x = x;
a.step = 0;
map[x] = 1;
Q.push(a);
while(!Q.empty())
{
a = Q.front();
Q.pop();
if(a.x == k)
return a.step;
next = a;
//每次都将三种状况加入队列之中
next.x = a.x+1;
if(check(next.x))
{
next.step = a.step+1;
map[next.x] = 1;
Q.push(next);
}
next.x = a.x-1;
if(check(next.x))
{
next.step = a.step+1;
map[next.x] = 1;
Q.push(next);
}
next.x = a.x*2;
if(check(next.x))
{
next.step = a.step+1;
map[next.x] = 1;
Q.push(next);
}
}
return -1;
}
int main()
{
int ans;
while(~scanf("%d%d",&n,&k))
{
memset(map,0,sizeof(map));
ans = bfs(n);
printf("%dn",ans);
}
return 0;
}


 

最后

以上就是负责小海豚为你收集整理的HDU2717:Catch That Cow(BFS)的全部内容,希望文章能够帮你解决HDU2717:Catch That Cow(BFS)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(43)

评论列表共有 0 条评论

立即
投稿
返回
顶部