概述
Rescue
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 36992 Accepted Submission(s): 12845
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.
Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
Input
First line contains two integers stand for N and M.
Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.
Process to the end of the file.
Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
Sample Output
13
Author
CHEN, Xue
Source
ZOJ Monthly, October 2003
Recommend
Eddy | We have carefully selected several similar problems for you: 1240 1016 1010 1072 1241
Statistic | Submit | Discuss | Note
BFS裸题,直接上模版套就可以了。
#include<algorithm>
#include<cstdio>
#include<iostream>
#include<cstring>
#include<queue>
#define INF 1000000
using namespace std;
const int MAXN=200+10;
int sx,sy,ex,ey;//起始点,终点坐标
int n,m;
char mp[MAXN][MAXN];
int d[MAXN][MAXN];
int dx[4]={1,0,-1,0},dy[4]={0,1,0,-1};
typedef pair<int,int> P;
void BFS(){
queue<P> q;
for(int i=0;i<n;i++){
for(int j=0;j<m;j++) d[i][j]=INF;
}
q.push(P(sx,sy));
d[sx][sy]=0;
while(!q.empty()){
P p=q.front();q.pop();
if(p.first==ex&&p.second==ey) break;
for(int i=0;i<4;i++){
int nx=p.first+dx[i],ny=p.second+dy[i];
if(nx>=0&&nx<n&&ny>=0&&ny<m&&mp[nx][ny]!='#'&&d[nx][ny]==INF){
if(mp[nx][ny]=='.'||mp[nx][ny]=='r') d[nx][ny]=d[p.first][p.second]+1;
else d[nx][ny]=d[p.first][p.second]+2;
q.push(P(nx,ny));
}
}
}
if(d[ex][ey]==INF) printf("Poor ANGEL has to stay in the prison all his life.n");
else printf("%dn",d[ex][ey]);
}
int main(){
while(~scanf("%d%d",&n,&m)){
for(int i=0;i<n;i++) scanf("%s",mp[i]);
for(int i=0;i<n;i++){
for(int j=0;j<m;j++){
if(mp[i][j]=='a'){
sx=i;
sy=j;
}
if(mp[i][j]=='r'){
ex=i;
ey=j;
}
}
}
BFS();
}
return 0;
}
最后
以上就是潇洒石头为你收集整理的HDU1242——Rescue【BFS】Rescue的全部内容,希望文章能够帮你解决HDU1242——Rescue【BFS】Rescue所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
发表评论 取消回复