我是靠谱客的博主 瘦瘦酒窝,最近开发中收集的这篇文章主要介绍RescueRescue,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Rescue

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 1235 Accepted Submission(s): 495
 
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.

Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.

You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)

 
Input
First line contains two integers stand for N and M.

Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.

Process to the end of the file.

 
Output

            For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."

 
Sample Input
7 8
#.#####.
#.a#..r.
#..#x...
..#..#.#
#...##..
.#......
........
 
Sample Output
13
 
Author
CHEN, Xue
 
Source
ZOJ Monthly, October 2003
 
Recommend
Eddy
 
/*
优先队列是反的
*/
#include<bits/stdc++.h>
#define N 205
using namespace std;
char mapn[N][N];
int n,m,res;
int visit[N][N];
int dir[4][2]={1,0,-1,0,0,1,0,-1};
struct node
{
    int x,y;
    int val;
    bool operator <(const node &b)const
    {
        return val>b.val;
    }
};
int ok(int x,int y)
{
    if(x<1||x>n||y<1||y>m||visit[x][y]||mapn[x][y]=='#')
        return 1;
    return 0;
}
int bfs(node start,int x,int y)
{
    int i;
    priority_queue<node>fr;
    fr.push(start);
    visit[start.x][start.y]=1;
    //int c=1;
    while(!fr.empty())
    {
        //cout<<c++<<endl;
        start=fr.top();
        fr.pop();
        //cout<<start.x<<" "<<start.y<<endl;
        if(start.x==x&&start.y==y)
            return start.val;
        //cout<<start.val<<endl;
        for(i=0;i<4;i++)
        {
            node v=start;
            v.x+=dir[i][0];
            v.y+=dir[i][1];
            if(ok(v.x,v.y)) continue;
            v.x=v.x;
            v.y=v.y;
            v.val++;
            if(mapn[v.x][v.y]=='x')
                v.val++;
            fr.push(v);
            visit[v.x][v.y]=1;
        }
    }
    return 0;
}
int main()
{
    // freopen("C:\Users\acer\Desktop\in.txt","r",stdin);
    while(~scanf("%d%d",&n,&m))
    {
        getchar();
        memset(visit,0,sizeof visit);
        node start;
        int ex,ey;
        for(int i=1;i<=n;i++)
        {
            for(int j=1;j<=m;j++)
            {
                scanf("%c",&mapn[i][j]);
                if(mapn[i][j]=='a')
                {
                    ex=i;
                    ey=j;
                }
                if(mapn[i][j]=='r')
                {
                    start.x=i;
                    start.y=j;
                    start.val=0;
                }
            }
            scanf("n");
        }//输入完成
        //cout<<start.x<<" "<<start.y<<endl;
        //cout<<ex<<" "<<ey<<endl;
        // for(int i=1;i<=n;i++)
        // {
            // for(int j=1;j<=m;j++)
                // cout<<mapn[i][j];
            // cout<<endl;
        // }
        int cur=0;
        cur=bfs(start,ex,ey);
        if(!cur)
            puts("Poor ANGEL has to stay in the prison all his life.");
        else
            printf("%dn",cur);
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/wuwangchuxin0924/p/5996897.html

最后

以上就是瘦瘦酒窝为你收集整理的RescueRescue的全部内容,希望文章能够帮你解决RescueRescue所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(38)

评论列表共有 0 条评论

立即
投稿
返回
顶部