我是靠谱客的博主 迷路小笼包,最近开发中收集的这篇文章主要介绍【搜索入门专题1】 hdu1242 J - Rescue c++ stl容器之优先队列+BFS Rescue,觉得挺不错的,现在分享给大家,希望可以做个参考。
概述
Rescue
Problem Description
Angel was caught by the MOLIGPY! He was put in prison by Moligpy. The prison is described as a N * M (N, M <= 200) matrix. There are WALLs, ROADs, and GUARDs in the prison.
Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
Angel's friends want to save Angel. Their task is: approach Angel. We assume that "approach Angel" is to get to the position where Angel stays. When there's a guard in the grid, we must kill him (or her?) to move into the grid. We assume that we moving up, down, right, left takes us 1 unit time, and killing a guard takes 1 unit time, too. And we are strong enough to kill all the guards.
You have to calculate the minimal time to approach Angel. (We can move only UP, DOWN, LEFT and RIGHT, to the neighbor grid within bound, of course.)
Input
First line contains two integers stand for N and M.
Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.
Process to the end of the file.
Then N lines follows, every line has M characters. "." stands for road, "a" stands for Angel, and "r" stands for each of Angel's friend.
Process to the end of the file.
Output
For each test case, your program should output a single integer, standing for the minimal time needed. If such a number does no exist, you should output a line containing "Poor ANGEL has to stay in the prison all his life."
Sample Input
7 8 #.#####. #.a#..r. #..#x... ..#..#.# #...##.. .#...... ........
Sample Output
13
题意:输入n,m.再输入n行,m列的字符,求从r到a的最小时间(并未要求是最优路径),'.'表示可以通过,花费时间为1,'#'表示无法通过,'s'表示可以通过,花费时间为2.
思路:先提示有坑,终点只有一个,起点却有多个,这道题我们逆向思考,搜索从终点到花费时间最少的起点,对于如何处理最小时间的问题,队友提示用优先队列,先搜索一个点的4个方向,4个方向中有满足的点加入队列,队列元素会按时间从小到大的顺序排列。自己也是第一次get c++的优先队列,所以用的比较简单的方法,其余的之后遇到再学。
#include<stdio.h>
#include<iostream>
#include<string.h>
#include<queue>
using namespace std;
#define N 220
char str[N][N];
int book[N][N];
int startx,starty;
int endx,endy;
int flag,sumtime;
int n,m;
struct node{
int x,y,time;
bool operator <(const node t)const//按照时间大小降序排列
{
return time > t.time ;
}
};
void BFS()
{
node start,now_q,next_q;
int NEXT[4][2] = {0,1,0,-1,-1,0,1,0};
int i;
priority_queue<node>Q;//定义优先队列
start.time = 0;
start.x = startx;
start.y = starty;
Q.push(start);
while(!Q.empty())
{
now_q = Q.top() ;//取队头元素和普通的不同
Q.pop() ;
if(now_q.x == endx&&now_q.y == endy)
{
flag = 1;
sumtime = now_q.time;
return ;
}
for(i = 0; i < 4; i ++)
{
next_q.x = now_q.x + NEXT[i][0];
next_q.y = now_q.y + NEXT[i][1];
if(next_q.x < 0||next_q.y <0||next_q.x > n-1||next_q.y > m-1)
continue;
if(!book[next_q.x][next_q.y]&&str[next_q.x][next_q.y]!='#')
{
book[next_q.x][next_q.y] = 1;
if(str[next_q.x][next_q.y] == 'x')
next_q.time = now_q.time + 2;
else
next_q.time = now_q.time + 1;
Q.push(next_q);
}
}
}
return;
}
int main()
{
int i,j;
while(scanf("%d%d",&n,&m)!=EOF)
{
flag = sumtime = 0;
memset(book,0,sizeof(book));
for(i = 0; i < n; i ++)
scanf("%s",str[i]);
for(i = 0; i < n; i ++)
{
for(j = 0; j < m; j ++)
{
if(str[i][j]== 'a')
{
book[i][j] = 1;
startx = i;
starty = j;
}
if(str[i][j] == 'r')
{
endx = i;
endy = j;
}
}
}
BFS();
if(flag)
printf("%dn",sumtime);
else
printf("Poor ANGEL has to stay in the prison all his life.n");
}
return 0;
}
最后
以上就是迷路小笼包为你收集整理的【搜索入门专题1】 hdu1242 J - Rescue c++ stl容器之优先队列+BFS Rescue的全部内容,希望文章能够帮你解决【搜索入门专题1】 hdu1242 J - Rescue c++ stl容器之优先队列+BFS Rescue所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复