我是靠谱客的博主 生动美女,最近开发中收集的这篇文章主要介绍UVA10271【Chopsticks】UVA10271【Chopsticks】,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

UVA10271【Chopsticks】

Description:

In China, people use a pair of chopsticks to get food on the table, but Mr. L is a bit different. He usesa set of three chopsticks – one pair, plus an EXTRA long chopstick to get some big food by piercing it through the food. As you may guess, the length of the two shorter chopsticks should be as close aspossible, but the length of the extra one is not important, as long as it’s the longest. To make things
clearer, for the set of chopsticks with lengths A, B, C (A ≤ B ≤ C), (A − B)* (A − B)is called the “badness”of the set.It’s December 2nd, Mr.L’s birthday! He invited K people to join his birthday party, and would liketo introduce his way of using chopsticks. So, he should prepare K + 8 sets of chopsticks(for himself,his wife, his little son, little daughter, his mother, father, mother-in-law, father-in-law, and K other
guests). But Mr.L suddenly discovered that his chopsticks are of quite different lengths! He should find a way of composing the K + 8 sets, so that the total badness of all the sets is minimized.

Input

The first line in the input contains a single integer T, indicating the number of test cases (1 ≤ T ≤ 20).
Each test case begins with two integers K, N (0 ≤ K ≤ 1000, 3K + 24 ≤ N ≤ 5000), the number of guests and the number of chopsticks.
There are N positive integers Li on the next line in non–decreasing order indicating the lengths of the chopsticks (1 ≤ Li ≤ 32000).

Output

For each test case in the input, print a line containing the minimal total badness of all the sets.

Note:

For the sample input, a possible collection of the 9 sets is:
8,10,16; 19,22,27; 61,63,75; 71,72,88; 81,81,84; 96,98,103; 128,129,148; 134,134,139; 157,157,160

Sample Input

1
1 40
1 8 10 16 19 22 27 33 36 40 47 52 56 61 63 71 72 75 81 81 84 88 96 98
103 110 113 118 124 128 129 134 134 139 148 157 157 160 162 164

Sample Output

23


Translation:

有n个数据,给定k,要从中选出k+8个三元组(x,y,z,其中x<=y<=z),每选一次的代价为(x-y)^2,求最小代价和。

Solution:

DP
状态:f[i][j]表示前i个数中选j对,令(ans)min.
转移方程:f[i][j]=min(f[i-1][j],f[i-2][j-1]+(a[i]-a[i-1])^2);
Tips :
1. 题中给定了一个不下降序列a[],这样就免得排序了。
2. 1<=i <=N-1
3. 1<=j <=k+8
4. 3*j <= i 不能枚举所有情况,如i=4,j=2不能成立,因为需要考虑第三根筷子
5. 巧妙的方法是倒着输入a[i],这样保证了前面的数一定大于后面的数,即保证了Z>max(X,Y)
Code:

#include <stdio.h>
#include <string.h>
#define MAXN 6000
#define INF 99999
int t,n,k;
int a[MAXN],f[MAXN][1700];
int min(int a,int b){return a<b?a:b;}
int cmp(int a,int b){return a<b?1:0;}
int main()
{
scanf("%d",&t);
while(t--)
{
memset(a,0,sizeof(a));
scanf("%d%d",&k,&n);
for(int i=n;i>=1;i--)
{
scanf("%d",&a[i]);
}
for(int i=1;i<=n;i++)
{
f[i][0]=0;
for(int j=1;j<=k+8;j++)
{
f[i][j]=INF;
}
}
for(int i=1;i<=n;i++)
{
for(int j=1;j<=k+8;j++)
{
if(3*j<=i)
f[i][j]=min(f[i-1][j],f[i-2][j-1]+(a[i]-a[i-1])*(a[i]-a[i-1]));
}
}
printf("%dn",f[n][k+8]);
}
return 0;
}

最后

以上就是生动美女为你收集整理的UVA10271【Chopsticks】UVA10271【Chopsticks】的全部内容,希望文章能够帮你解决UVA10271【Chopsticks】UVA10271【Chopsticks】所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(35)

评论列表共有 0 条评论

立即
投稿
返回
顶部