概述
题目描述
请补充“#define SWAP(a,b) …”,其功能是交换a与b的数据。
#include <stdio.h>
/******************************************/
/// Write your code here,
/// beginning with “#define”…
/******************************************/
int main()
{
int a, b;
while(~scanf("%d%d", &a, &b))
{
if(a < 5) {
SWAP(a, b);
} else {
a = b;
}
printf("%d %dn", a, b);
}
SWAP(a, a);
printf("%d %dn", a, a);
return 0;
}
样例输入 Copy
0 1
1 0
样例输出 Copy
1 0
0 1
0 0
代码
#include <stdio.h>
/******************************************/
/// Write your code here,
///
beginning with "#define"...
#define SWAP(a,b) {a=b-a;b=b-a;a=a+b;}
/******************************************/
int main()
{
double a, b;
while(~scanf("%lf%lf", &a, &b))
{
if(a < 5.0)
{
SWAP(a, b);
}
else
{
a = b;
}
printf("%.0f %.0fn", a, b);
}
//SWAP(a, a);
printf("%.0f %.0fn", a, a);
return 0;
}
最后
以上就是机灵苗条为你收集整理的C语言 宏定义练习:交换数据的全部内容,希望文章能够帮你解决C语言 宏定义练习:交换数据所遇到的程序开发问题。
如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。
本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
发表评论 取消回复