我是靠谱客的博主 危机香菇,这篇文章主要介绍stars,现在分享给大家,希望可以做个参考。

B - Stars
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u
Submit   Status

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars.  



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3.  

You are to write a program that will count the amounts of the stars of each level on a given map.
 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.
 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.
 

Sample Input

复制代码
1
2
3
4
5
6
7
8
9
10
5 1 1 5 1 7 1 3 3 5 5
 

Sample Output

复制代码
1
2
3
4
5
6
7
8
9
1 2 1 1 0
 


#include <iostream>
#include <string.h>
#include <stdio.h>
using namespace std;
const int maxn = 32005;
int c[maxn];
int ans[maxn];
int lowbit(int x)  {
    return x&(-x);
}
void add(int x){
    while(x<=maxn){
        c[x]+=1;   x+=lowbit(x);
    }
}
int sum(int x){
    int ret=0;
    while(x>0){
       ret+=c[x];  x-=lowbit(x);
    }
    return ret;
}
int main(){
    int n,x,y,i;
    while(scanf("%d",&n)!=EOF){
        memset(ans,0,sizeof(ans));
        memset(c,0,sizeof(c));
        for(i=0;i<n;i++){
             scanf("%d %d",&x,&y);

             ans[ sum(++x)]++;

             add(x);
        }
        for(i=0;i<n;i++)
        printf("%dn",ans[i]);

    }

   return 0;
}

最后

以上就是危机香菇最近收集整理的关于stars的全部内容,更多相关stars内容请搜索靠谱客的其他文章。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(52)

评论列表共有 0 条评论

立即
投稿
返回
顶部