我是靠谱客的博主 幸福酒窝,最近开发中收集的这篇文章主要介绍【POJ 3628】Bookshelf 2(01背包),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal ‘excess’ height between the optimal stack of cows and the bookshelf.

Input

  • Line 1: Two space-separated integers: N and B
  • Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

  • Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

题目大意

很经典的一题01背包,大概意思就是说每一只奶牛都有一个高度Hi,同时有一个高度为B的奶牛书库(百度翻译的,我也不知道是什么东西)。从这几只奶牛中选几只,使得这些奶牛的高度和 大于 奶牛书库的高度B 同时 要使这些奶牛的高度和 与 奶牛书库的高度和 的差尽可能的小

思路

先跑一遍01背包

for(int i=1;i<=n;i++)
{
for(int j=sum;j-v[i]>=0;j--)
{
dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
if(dp[j]>=b&&dp[j]<ans) ans=dp[j];
}
}

在跑的的同时判断我当前的dp[j]是否满足dp[j]>b&&dp[j]

代码

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
using namespace std;
const int maxn=20*100000+5;
const int INF=99999999;
int dp[maxn],v[maxn],n,b;
int main()
{
while(~scanf("%d %d",&n,&b))
{
memset(dp,0,sizeof(dp));
int sum=0;
for(int i=1;i<=n;i++)
{
scanf("%d",&v[i]);
sum+=v[i];
}
int ans;
for(int i=1;i<=n;i++)
{
for(int j=sum;j-v[i]>=0;j--)
{
dp[j]=max(dp[j],dp[j-v[i]]+v[i]);
if(dp[j]>=b&&dp[j]<ans) ans=dp[j];
}
}
printf("%dn",abs(ans-b));
}
return 0;
}

最后

以上就是幸福酒窝为你收集整理的【POJ 3628】Bookshelf 2(01背包)的全部内容,希望文章能够帮你解决【POJ 3628】Bookshelf 2(01背包)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(54)

评论列表共有 0 条评论

立即
投稿
返回
顶部