我是靠谱客的博主 醉熏世界,最近开发中收集的这篇文章主要介绍HDU - 1394,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

第二天叫醒我的不是闹钟,是梦想!

The inversion number of a given number sequence a1, a2, …, an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, …, an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, …, an-1, an (where m = 0 - the initial seqence)
a2, a3, …, an, a1 (where m = 1)
a3, a4, …, an, a1, a2 (where m = 2)

an, a1, a2, …, an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
Output
For each case, output the minimum inversion number on a single line.
Sample Input
10
1 3 6 9 0 8 5 7 4 2
Sample Output
16

树状数组;求逆序数
首先题目是0----n-1.我们要把它对齐,读入的时候全部都加1,然后我们只要循环一遍1----n中的逆序数对有多少。然后这边有个思维,假设现在我们逆序数为ans,把a[i]移到最后,那么我们少了ans-a[i]个逆序数,但同时我们又多了n-a[i]-1个逆序数,所以答案就是ans-a[i]+n-a[i]-1;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
const int N=1e5+10;
const int INF=0x3f3f3f3f;
const int maxn=5000;
int a[N],c[N];
int n;
int lowbit(int x)
{
  return x&(-x);
}
void add(int i,int x)
{
  while(i<=maxn)
  {
    c[i]+=x;
    i+=lowbit(i);
  }
}
int sum(int i)
{
  int res=0;
  while(i>0)
  {
    res+=c[i];
    i-=lowbit(i);
  }
  return res;
}
int main()
{
  while(~scanf("%d",&n))
  {
      int ans=0;
      memset(c,0,sizeof(c));
      for(int i=1;i<=n;i++)
      {
        cin>>a[i];
        a[i]++;
        ans+=sum(maxn)-sum(a[i]);
        add(a[i],1);
      }
    //  cout<<ans<<endl;
      int  res=ans;
      for(int i=1;i<n;i++)
      {
          ans+=n-2*a[i]+1;   //这边+1是因为下标从1开始了
        //  cout<<ans<<endl;
          res=min(res,ans);
      }
      cout<<res<<endl;
  }
}

最后

以上就是醉熏世界为你收集整理的HDU - 1394的全部内容,希望文章能够帮你解决HDU - 1394所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(69)

评论列表共有 0 条评论

立即
投稿
返回
顶部