我是靠谱客的博主 土豪菠萝,最近开发中收集的这篇文章主要介绍hdu-5673 Robot(默次金数),觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

题目链接:

Robot

Time Limit: 12000/6000 MS (Java/Others)
 Memory Limit: 65536/65536 K (Java/Others)
问题描述
有一个机器人位于坐标原点上。每秒钟机器人都可以向右移到一个单位距离,或者在原地不动。如果机器人的当前位置在原点右侧,它同样可以
向左移动单位距离。一系列的移动(左移,右移,原地不动)定义为一个路径。问有多少种不同的路径,使得nn秒后机器人仍然位于坐标原点? 答案可能很大,只需输出答案对1,000,000,0071,000,000,007的模。
输入描述
输入包含多组数据. 第一行有一个整数T (1leq Tleq 100)T(1T100), 表示测试数据的组数. 对于每组数据: 输入一个整数 n (1leq nleq 1,000,000)n(1n1,000,000)。 
输出描述
对于每组数据,输出一个整数
输入样例
3
1
2
4
输出样例
1
2
9

思路:

比赛的时候一直推不出公式,还是得好好补补组合数学;

AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#include <stack>
#include <map>
using namespace std;
typedef long long ll;
const ll mod=1e9+7;
const int N=1e6+6;
ll dp[N];

ll fastpow(ll a,ll b)
{
    ll ans=1,base=a;
    while(b)
    {
        if(b&1)
        {
            ans=ans*base;
            ans%=mod;
        }
        base*=base;
        base%=mod;
        b=(b>>1);
    }
    return ans;
}
void fun()
{
    dp[1]=1;
    dp[2]=2;
    for(int i=3;i<N;i++)
    {
        ll x=(ll)(i+3);
        ll y=(ll)(2*i+1);
        ll z=(ll)(3*i-3);
        dp[i]=(y*dp[i-1]%mod+z*dp[i-2]%mod)*fastpow((ll)(i+2),mod-2)%mod;
    }
}
int main()
{
    int t;
    scanf("%d",&t);
    fun();
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%I64dn",dp[n]);
    }

    return 0;
}

 

转载于:https://www.cnblogs.com/zhangchengc919/p/5423114.html

最后

以上就是土豪菠萝为你收集整理的hdu-5673 Robot(默次金数)的全部内容,希望文章能够帮你解决hdu-5673 Robot(默次金数)所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(50)

评论列表共有 0 条评论

立即
投稿
返回
顶部