我是靠谱客的博主 魔幻睫毛膏,最近开发中收集的这篇文章主要介绍STL应用特训:团队队列(Team Queue UVA540)队列的使用,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

解题思路:根据题意可定义多个队列,总队列定义一个,用于存放队伍编号的排列。其余队列存放各队伍内部的排列。用map将个人编号和队伍编号一一对应。

题目描述:

总时间限制: 

2000ms

 

内存限制: 

65536kB

描述

Queues and Priority Queues are data structures which are known to most computer scientists. The Team Queue, however, is not so well known, though it occurs often in everyday life. At lunch time the queue in front of the Mensa is a team queue, for example. 

In a team queue each element belongs to a team. If an element enters the queue, it first searches the queue from head to tail to check if some of its teammates (elements of the same team) are already in the queue. If yes, it enters the queue right behind them. If not, it enters the queue at the tail and becomes the new last element (bad luck). Dequeuing is done like in normal queues: elements are processed from head to tail in the order they appear in the team queue. 

Your task is to write a program that simulates such a team queue.

输入

The input will contain one or more test cases. Each test case begins with the number of teams t (1 <= t <= 1000). Then t team descriptions follow, each one consisting of the number of elements belonging to the team and the elements themselves. Elements are integers in the range 0 - 999999. A team may consist of up to 1000 elements. 
Finally, a list of commands follows. There are three different kinds of commands: 

  • ENQUEUE x - enter element x into the team queue 
  • DEQUEUE - process the first element and remove it from the queue 
  • STOP - end of test case


The input will be terminated by a value of 0 for t. 
Warning: A test case may contain up to 200000 (two hundred thousand) commands, so the implementation of the team queue should be efficient: both enqueing and dequeuing of an element should only take constant time.

输出

For each test case, first print a line saying "Scenario #k", where k is the number of the test case. Then, for each DEQUEUE command, print the element which is dequeued on a single line. Print a blank line after each test case, even after the last one.

样例输入

2
3 101 102 103
3 201 202 203
ENQUEUE 101
ENQUEUE 201
ENQUEUE 102
ENQUEUE 202
ENQUEUE 103
ENQUEUE 203
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
2
5 259001 259002 259003 259004 259005
6 260001 260002 260003 260004 260005 260006
ENQUEUE 259001
ENQUEUE 260001
ENQUEUE 259002
ENQUEUE 259003
ENQUEUE 259004
ENQUEUE 259005
DEQUEUE
DEQUEUE
ENQUEUE 260002
ENQUEUE 260003
DEQUEUE
DEQUEUE
DEQUEUE
DEQUEUE
STOP
0

样例输出

Scenario #1
101
102
103
201
202
203

Scenario #2
259001
259002
259003
259004
259005
260001
#include<cstdio>
#include<queue>
#include<map>
#include<string>
#include<iostream>
using namespace std;

map<int,int> team;            //map映射个人编号和队伍编号  

int main()
{
	int n;
	int countn=0;
	while(1)
	{
		cin>>n;
		if(n==0) break;
		countn++;
		cout<<"Scenario #"<<countn<<endl;
		for(int i=1;i<=n;i++)
		{
			int ci;
			cin>>ci;
			for(int j=0;j<ci;j++)
			{
				int x;
				cin>>x;
				team[x]=i;         //映射表示x为第i队 
			}
		}
		queue<int> q,q2[1000];    //定义一个总队列,存队伍序号。定义更多的队列存各队伍排列。 
		string s;
		while(1)
		{
			cin>>s;
			if(s[0]=='S') break;
			if(s[0]=='D')
			{
				int t=q.front();
				cout<<q2[t].front()<<endl;
				q2[t].pop();
				if(q2[t].empty()==true) q.pop();     //若队伍内无人,表示总队伍中已无此队伍,该编号弹出 
			}
			if(s[0]=='E')
			{
				int x;
				cin>>x;
				int t=team[x];
				if(q2[t].empty()==true)             //若队伍内无人,表示该编号的队伍还未加入总队,在此加入。 
				{
					q.push(t);
				}
				q2[t].push(x);
			}
		}
		cout<<endl;
	}
	
	return 0;
} 

 

最后

以上就是魔幻睫毛膏为你收集整理的STL应用特训:团队队列(Team Queue UVA540)队列的使用的全部内容,希望文章能够帮你解决STL应用特训:团队队列(Team Queue UVA540)队列的使用所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(56)

评论列表共有 0 条评论

立即
投稿
返回
顶部