我是靠谱客的博主 威武河马,最近开发中收集的这篇文章主要介绍HDU 2604 Queuing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Problem Description

Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.

Input

Input a length L (0 <= L <= 10  6) and M.

Output

Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.

Sample Input

3 8
4 7
4 8

Sample Output

6
2

1

矩阵快速幂。

#include<stdio.h>
#include<string.h>
#include<vector>
#include<queue>
#include<functional>
using namespace std;
const int maxn = 1000005;
const int size = 4;
int n, m, ans, f[size], p[size];

struct abc
{
    int a[size][size];
    abc(){ memset(a, 0, sizeof(a)); }
    void operator =(const abc&b) { memcpy(a, b.a, sizeof(a)); }
    abc operator *(const abc&b) {
        abc c;
        for (int i = 0; i < size;i++)
            for (int j = 0; j < size;j++)
                for (int k = 0; k < size; k++)
                    c.a[i][k] = (c.a[i][k] + a[i][j] * b.a[j][k]) % m;
        return c;
    }
};

abc get(int x)
{
    abc a, b, c;
    a.a[0][1] = a.a[1][3] = a.a[2][0] = a.a[2][1] = a.a[3][2] = a.a[3][3] = 1;
    for (int i = 1, f = 0; x; x >>= 1)
    {
        if (x & 1) 
            if (f) b = b * a; else b = a, f = 1;
        a = a * a;
    }
    return b;
}

int solve()
{
    int tot = 0;
    abc a = get(n - 2);
    memset(p, 0, sizeof(p));
    f[0] = f[1] = f[2] = f[3] = 1;
    for (int j = 0; j < size; j++)
        for (int k = 0; k < size; k++)
            p[k] = (p[k] + f[j] * a.a[j][k]) % m;
    for (int j = 0; j < size; j++) tot = (tot + p[j]) % m;
    return tot;
}

int main()
{
    while (scanf("%d%d", &n, &m) == 2)
    {
        if (n <= 2){ ans = 2 * n % m; }
        else ans = solve();
        printf("%dn", ans);
    }
    return 0;
}


最后

以上就是威武河马为你收集整理的HDU 2604 Queuing的全部内容,希望文章能够帮你解决HDU 2604 Queuing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(41)

评论列表共有 0 条评论

立即
投稿
返回
顶部