我是靠谱客的博主 曾经马里奥,最近开发中收集的这篇文章主要介绍hdu 2604 Queuing(矩阵优化递推公式) Queuing,觉得挺不错的,现在分享给大家,希望可以做个参考。

概述

Queuing

                                              Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
                                                                          Total Submission(s): 2842    Accepted Submission(s): 1305


Problem Description
Queues and Priority Queues are data structures which are known to most computer scientists. The Queue occurs often in our daily life. There are many people lined up at the lunch time. 

  Now we define that ‘f’ is short for female and ‘m’ is short for male. If the queue’s length is L, then there are 2 L numbers of queues. For example, if L = 2, then they are ff, mm, fm, mf . If there exists a subqueue as fmf or fff, we call it O-queue else it is a E-queue.
Your task is to calculate the number of E-queues mod M with length L by writing a program.
 

Input
Input a length L (0 <= L <= 10  6) and M.
 

Output
Output K mod M(1 <= M <= 30) where K is the number of E-queues with length L.
 

Sample Input
  
  
3 8 4 7 4 8
 

Sample Output
  
  
6 2 1
 

Author
WhereIsHeroFrom
 

递推公式f(n)=f(n-1)+f(n-3)+f(n-4)
递推过程:
现在设长度为n
1,在最后一位加m时,前面无论是什么都满足,得f(n-1);
2,在 最后一位加f时,倒数后2位无论加什么都不能满足,于是讨论倒数后3位,后3位可以加mmf,即+f(n-3),现在还有      一种情况没考虑到,那就是mff,可能前面是以f结尾,于是讨论倒数后4位,在后4位上加mmff,即+f(n-4)。
得到递推公式就可以构造矩阵了。


代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
struct matrix
{
    int ma[10][10];
};
int mod;
matrix multi(matrix x,matrix y)
{
    matrix ans;
    memset(ans.ma,0,sizeof(ans.ma));
    for(int i=1;i<=4;i++)
    {
        for(int j=1;j<=4;j++)
        {
            if(x.ma[i][j])
            {
                for(int k=1;k<=4;k++)
                {
                    ans.ma[i][k]=(ans.ma[i][k]+(x.ma[i][j]*y.ma[j][k])%mod)%mod;
                }
            }
        }
    }
    return ans;
}
matrix pow(matrix a,int k)
{
    matrix ans;
    for(int i=1;i<=4;i++)
    {
        for(int j=1;j<=4;j++)
        {
            if(i==j)
            ans.ma[i][j]=1;
            else
            ans.ma[i][j]=0;
        }
    }
    while(k)
    {
        if(k&1)
        ans=multi(ans,a);
        a=multi(a,a);
        k=k>>1;
    }
    return ans;
}
int main()
{
    int n;
    while(~scanf("%d%d",&n,&mod))
    {
        matrix a,b;
        memset(a.ma,0,sizeof(a.ma));
        memset(b.ma,0,sizeof(b.ma));
        a.ma[1][1]=a.ma[1][3]=a.ma[1][4]=1;
        a.ma[2][1]=a.ma[3][2]=a.ma[4][3]=1;
        b.ma[1][1]=6;
        b.ma[2][1]=4;
        b.ma[3][1]=2;
        b.ma[4][1]=1;
        if(n==0)
        {
            printf("%dn",1%mod);
            continue;
        }
        if(n==1)
        {
            printf("%dn",2%mod);
            continue;
        }
        if(n==2)
        {
            printf("%dn",4%mod);
            continue;
        }
        if(n==3)
        {
            printf("%dn",6%mod);
            continue;
        }
        a=pow(a,n-3);
        b=multi(a,b);
        printf("%dn",b.ma[1][1]);
    }
    return 0;
}




最后

以上就是曾经马里奥为你收集整理的hdu 2604 Queuing(矩阵优化递推公式) Queuing的全部内容,希望文章能够帮你解决hdu 2604 Queuing(矩阵优化递推公式) Queuing所遇到的程序开发问题。

如果觉得靠谱客网站的内容还不错,欢迎将靠谱客网站推荐给程序员好友。

本图文内容来源于网友提供,作为学习参考使用,或来自网络收集整理,版权属于原作者所有。
点赞(48)

评论列表共有 0 条评论

立即
投稿
返回
顶部